Bug 155871 - Spaceball 4000flx doesn't work
Summary: Spaceball 4000flx doesn't work
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: joystick (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 03:40 UTC by Gregory Maxwell
Modified: 2012-09-28 11:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 13:47:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregory Maxwell 2005-04-25 03:40:29 UTC
Description of problem:
Both inputattach and jsattach fail to init my spaceball 4000flx

Version-Release number of selected component (if applicable):

gpm-1.20.1-66
joystick-1.2.15-18


How reproducible:

Every time.

Steps to Reproduce:
1. modprobe spaceball
2. attach spaceball to serial port
3. inputattach --spaceball /dev/ttyUSB0 
  
Actual results:

Spaceball beeps
inputattach: device initialization failed

or (using jsattach --sball4)

Spaceball beeps
jsattach: can't set line discipline


Expected results:

Spaceball beeps
Spaceball works

Additional info:

Linux gmaxlpt 2.6.10-1.741_FC3 #1 Thu Jan 13 16:38:22 EST 2005 i686 i686 i386
GNU/Linux

Spaceball is on a usbserial device.

Botton of strace on inputattach:

write(3, "@", 1)                        = 1
write(3, "\r", 1)                       = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 1 (in [3], left {0, 995000})
read(3, "?", 1)                         = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 1 (in [3], left {1, 0})
read(3, "F", 1)                         = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 1 (in [3], left {1, 0})
read(3, "T", 1)                         = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 1 (in [3], left {1, 0})
read(3, "@", 1)                         = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 1 (in [3], left {1, 0})
read(3, "\r", 1)                        = 1
select(4, [3], NULL, NULL, {0, 1000000}) = 0 (Timeout)
write(2, "inputattach: device initializati"..., 42inputattach: device
initialization failed
) = 42
exit_group(1)                           = ?

Comment 1 Ngo Than 2006-01-16 12:03:33 UTC
For debugging, couuld you please attach your /etc/modprobe.conf and 
the output of "dmesg | grep -i Joystick"

it looks like a problem in the driver. Thanks


Comment 2 John Thacker 2006-04-30 13:47:16 UTC
No response from reporter to request for info.
Also, FC3 is the responsibility of Fedora Legacy.
If the reporter can offer the needed information and this still
occurs in FC4 or FC5, please reopen.

Comment 3 Alex Smirnoff 2012-09-28 11:15:16 UTC
Please reopen!


Note You need to log in before you can comment on or make changes to this bug.