Bug 155873 - snmpd will not start under fc3 default
Summary: snmpd will not start under fc3 default
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
: 155874 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 06:22 UTC by Rob Kearey
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-08 13:25:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Kearey 2005-04-25 06:22:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
snmpd will not start under fc3 with targeted policy enabled. It starts fine when selinux is set to permissive mode.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.96

How reproducible:
Always

Steps to Reproduce:
1. set selinux to enforcing mode
2. start snmpd
3. ... watch it silently fail
  

Actual Results:  snmpd fails to start

Expected Results:  snmpd should start as normail

Additional info:

audit(1114408867.443:0): avc:  denied  { read } for  pid=3785 exe=/usr/sbin/snmpd name=config dev=dm-0 ino=488072 scontext=root:system_r:snmpd_t tcontext=system_u:object_r:selinux_config_t tclass=file
audit(1114408867.444:0): avc:  denied  { getattr } for  pid=3785 exe=/usr/sbin/snmpd path=/etc/selinux/config dev=dm-0 ino=488072 scontext=root:system_r:snmpd_t tcontext=system_u:object_r:selinux_config_t tclass=file

Comment 1 Daniel Walsh 2005-04-25 14:59:19 UTC
Are you seeing this AVC mesages generated in enforcing mode?

These messages usually show up in permissive mode. 

Clear you log files before starting snmpd and turn enforcing on and see if any
AVC messages are generated?

Dan

Comment 2 Rob Kearey 2005-04-25 23:32:03 UTC
Yes, you're right, sorry - I was seeing this in permissive mode. I'll retest today.

Comment 3 Daniel Walsh 2005-04-26 19:29:20 UTC
*** Bug 155874 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2005-05-12 17:27:20 UTC
Any update on this bug?

Comment 5 Rob Kearey 2005-05-13 00:40:05 UTC
Haven't had a chance to kick it yet, I'll do so tonight.

Comment 6 Rob Kearey 2005-05-30 01:09:38 UTC
Doesn't turn up in enforcing mode.

Comment 7 Daniel Walsh 2005-05-30 09:44:39 UTC
So snmp is working?

Comment 8 Rob Kearey 2005-06-09 06:33:00 UTC
snmpd is working.


Note You need to log in before you can comment on or make changes to this bug.