Bug 155876 - grubby probes non-existent floppy drive
grubby probes non-existent floppy drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
bzcl34nup
:
: 155941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-25 04:07 EDT by Joachim Backes
Modified: 2008-05-03 18:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-03 18:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2005-04-25 04:07:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
When installing the grub bootloader, each time I get an error msg concerning the floppy drive. Therfore I tried to use "grub-install --no-floppy", but I still get floppy error messages:

grub-install --no-floppy '(hd0,0)'
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0


Version-Release number of selected component (if applicable):
grub-0.95-3

How reproducible:
Always

Steps to Reproduce:
1.grub-install --no-floppy '(hd0,0)'
2.
3.
  

Actual Results:  See description.

Expected Results:  No floppy error msg

Additional info:

--
Comment 1 Peter Jones 2005-05-05 23:27:58 EDT
*** Bug 155941 has been marked as a duplicate of this bug. ***
Comment 2 Orion Poplawski 2005-05-06 16:02:52 EDT
This bug is impacting OS installs on floppyless systems and would be nice to see
fixed for FC4
Comment 3 Joachim Backes 2005-05-09 00:54:49 EDT
Wondering about "floppyless systems"! My system is equipped with an 1.44 MB
floppy drive.
Comment 4 Pekka Pietikäinen 2006-02-21 08:37:52 EST
Updating to fc5test3 since the bug still seems to be around, --no-floppy 
doesn't properly ignore the floppy drive completely if one is mentioned in
device.map.

My failure mode for this is with pm-hibernate, which tries to update the grub
config (presumably to boot with the same kernel that just hibernated). Since I
don't have a floppy drive

Removing fd0 from device.map fixed things for me. My laptop (X31) doesn't have 
one, a floppy controller sure. device.map was "created by anaconda" so I suppose
that direction might be to blame too. Should it even be putting fd0 in
devices.map, I don't think having it there by default is very useful?
Comment 5 Peter Jones 2006-03-08 17:36:02 EST
So, I haven't fixed this yet, but I am taking the fd0 entry out of newly created
device.map files (fix is in booty).
Comment 6 Orion Poplawski 2006-11-03 16:30:44 EST
It appears that grub-0.97-13 no longer reads device.map and so no longer can be
made to avoid the floppy device.  This causes grubby to hang for a while when
installing new kernels.  It appears that it scans /sys/block/, and since the
floppy module is loaded (why?) there is a /sys/block/fd0 entry and it tries to
open it.
Comment 7 Orion Poplawski 2007-04-24 19:14:32 EDT
Any idea what can be done here?  Seems to impact all kernel installs now, and
not installing grub during initial install.
Comment 8 Chuck Ebbert 2007-04-24 19:25:46 EDT
Why in the world would grub want to scan everything in /sys/block ?????
That could be a very long list.

Comment 9 Bug Zapper 2008-04-03 12:06:53 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Joachim Backes 2008-04-04 04:18:59 EDT
I tried the same under F8. No more error message!
Comment 11 Peter van Egdom 2008-05-03 18:30:52 EDT
Thank you for the bug report. Closing bug as per comment #10.

Note You need to log in before you can comment on or make changes to this bug.