Bug 155892 - Large (but smaller than MTU) packets on loopback interface fails.
Large (but smaller than MTU) packets on loopback interface fails.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Miller
Brian Brock
:
: 168665 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-25 10:25 EDT by Björn Augustsson
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 17:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn Augustsson 2005-04-25 10:25:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.4) Gecko/20050318 Red Hat/1.4.4-1.3.5

Description of problem:
Today one box (Dell PE 750) running rhel3 stopped being able to send mail, run up2date and OMSA (Dell server management app).

The reason turned out to be that largeish packets could not be transmitted over the loopback interface (lo). MTU on that interface is 16436, but I could only send packets up to and including 8033 bytes in length. 8034 failed. Ie

[august@wally august]$ ping -s 8005 localhost
PING localhost.localdomain (127.0.0.1) 8005(8033) bytes of data.
8013 bytes from localhost.localdomain (127.0.0.1): icmp_seq=0 ttl=64 time=0.051 ms
8013 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.036 ms
[...]
^C
[august@wally august]$ ping -s 8006 localhost
PING localhost.localdomain (127.0.0.1) 8006(8034) bytes of data.
[Nothing, hangs]
^C

Doing "service network restart" didn't help. Explicitly setting the MTU to 8000 worked. ("ifconfig lo mtu 8000") I had to restart a few hung sendmail processes, but then everything worked.

The machine runs a test instance of a calendar app and has very light load.

I've seen this before, a while ago, on another machine (Dell Dimension 8300). Can't be sure, but around "kernel-2.4.21-9"-ish. So this isn't a new bug, if that helps. I'm not sure if the exact numbers (8033/8034) was the same then, but in the same ballpark. IIRC I set the MTU to 8000 last time too, and that did the trick. This machine is my personal workstation, and it sees pretty standard sysadmin workstation loads.

It has only happened three times that I know of here, over about two years and 20-30 machines. It seems to happen to machines with long uptimes.

I have no idea what causes it. Sorry.

/August.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-27.0.2.EL

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. I have no idea how to reproduce this.
2.
3.
  

Additional info:
Comment 1 David Miller 2005-04-26 19:05:28 EDT
What is the MTU of the loopback device when the problem triggers?

This behavior can happen, I believe, in the IPSEC backport we did
to 2.4.x if the MTU of the device is not a strict multiple of 8
which is why ethernet never sees this.

The bug fix would be very invasive to backport and integrate into
the RHEL3 kernel at this point, so a better workaround might be
to force a multiple of 8 MTU on the loopback device.
Comment 2 Björn Augustsson 2005-04-27 02:06:50 EDT
The MTU is unchanged from the default. It is 16436, which indeed isn't a
multiple of 8.

I'll try setting it to 16432 on a bunch of machines, but since the bug happens
so rarely, it'd be hard to tell if it actally helped or not.

Any ideas on how to provoke it?
Comment 3 Björn Augustsson 2005-05-10 04:00:38 EDT
FYI It happened again today (on the same machine as last time.) 
Actually a couple of days ago, but I just noticed.

This time the biggest sendable packet was bigger though:

[august@wally august]$ ping -s 16198 localhost
PING localhost.localdomain (127.0.0.1) 16198(16226) bytes of data.
                                                                               
                                                            
--- localhost.localdomain ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2012ms
                                                                               
                                                            
[august@wally august]$ ping -s 16197 localhost
PING localhost.localdomain (127.0.0.1) 16197(16225) bytes of data.
16205 bytes from localhost.localdomain (127.0.0.1): icmp_seq=0 ttl=64 time=0.061 ms
                                                                               
                                                            
--- localhost.localdomain ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.061/0.061/0.061/0.000 ms, pipe 2

This machine did not have the lower (mod 8) MTU set (as discussed earlier)
I'll add that now. 
(Added MTU=16432 to /etc/sysconfig/network-scripts/ifcfg-lo )

/August.
Comment 4 Björn Augustsson 2005-05-23 03:56:29 EDT
Well, it happened again on the same box, and this time I had set the MTU to
16432, as I wrote above. 16432 is divisible with 8. (16, in fact.)

The uptime was about 10 days, since last time.

The magic number this time seems to be 16225, any more than that and it doesn't
work.

The kernel is still 2.4.21-27.0.4.ELsmp, but I'll get it up to the new -32
kernel ASAP, probably today.

[root@wally root]# ping -s 16197 localhost
PING localhost.localdomain (127.0.0.1) 16197(16225) bytes of data.
16205 bytes from localhost.localdomain (127.0.0.1): icmp_seq=0 ttl=64 time=0.061 ms
16205 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.059 ms
16205 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.054 ms
16205 bytes from localhost.localdomain (127.0.0.1): icmp_seq=3 ttl=64 time=0.054 ms
                                                                               
                         
--- localhost.localdomain ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3011ms
rtt min/avg/max/mdev = 0.054/0.057/0.061/0.003 ms, pipe 2
[root@wally root]# ping -s 16198 localhost
PING localhost.localdomain (127.0.0.1) 16198(16226) bytes of data.
                                                                               
                         [ a long time, no packets. ^c ]
--- localhost.localdomain ping statistics ---
0 packets transmitted, 0 received
                                                                               
                         
[root@wally root]#

/August.
Comment 5 Alfred Mikota 2005-10-13 04:21:45 EDT
Hi August!
I have the same problem with Kernel 2.4.21-27.0.2.ELsmp.
Did you already update the kernel and did this solve your problem?

Comment 6 Björn Augustsson 2005-10-13 08:00:41 EDT
Yeah, I've updated to 2.4.21-32.0.1, but that didn't help. 

I'll get it up to the latest (2.4.21-37) asap.

It's interesting that someone else also gets hit by this.

What kind of hardware and load are you running?

/August.
Comment 7 Alfred Mikota 2005-10-13 08:55:33 EDT
We are using Tivoli TSM for Backup and after execution the loopback device is
not functioning properly. Hardware is: 2 x IBM e365 with 6 GB MEM. Maybe the
problem is the huge amount of memory > 4 GB, but this is only a mind.
Comment 8 Björn Augustsson 2005-10-13 09:42:20 EDT
OK. As I wrote above, we run a test instance of a calendar server 
(Oracle Calendar). It does not happen to the production server (fortunately!)
for some reason.

We only have 1 GB of memory, and a single CPU (with HT).

Hmm. Not a lot of overlap... 

/August.
Comment 9 junichi NAKANO 2005-12-26 23:42:55 EST
Even I am worrying with the same phenomenon.

# ping-s 16,197 localhost
Although it is O.K.

# ping-s 16,198 localhost
It is NG.

When I do the following test with the same machine, the communication does the 
stall.
# cat/dev/zero|nc-l-p 8888
# nice nc localhost 8888>/dev/null

Because the such feeling that resembles in the matter of this did it it tried 
to do it.
http://lists. osdl. org/pipermail/bridge/2003-October/000066.html

The present changes MTU to 1500 (the same value as eth0) and be seeing the 
situation.
# ifconfig lo mtu 1500
When it changes it to this setting the communication stops doing the stall.

When it returns it to the source it does (# ifconfig lo mtu 16,436) the 100% 
stall.
Also it comes to be able to communicate normally (# ifconfig lo mtu 1500) when 
MTU is set up in 1500.

the stall comes to occur after that, although 1 to 2 days are safe, when the 
machine is restarted.

One unit does not occur at all, although actually, almost there are the same 
machine 2 units and 1 unit, although the stall occurs frequently.

I am Japanese.  I used translation software because English is not produced.
Please permit even if it is strange English.

Comment 10 junichi NAKANO 2005-12-27 00:11:01 EST
URL was wrong.
Http://lists.osdl.org/pipermail/bridge/2003-October/000066.html

The server is Pentium 4 630 (3GHz: L2 2MB) Hyper-Threading / LGA775 (with NX 
bit) / Mem 2GB / SATA 
---
Dec 21 10:20:15 www2 syslogd 1.4.1: restart.
Dec 21 10:20:15 www2 syslog: syslogd startup succeeded
Dec 21 10:20:15 www2 kernel: klogd 1.4.1, log source = /proc/kmsg started.
Dec 21 10:20:15 www2 kernel: Linux version 2.4.21-37.ELsmp 
(bhcompile@tweety.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 
3.2.3-53)) #1 SMP Wed Sep 7 13:28:55 EDT 2005
Dec 21 10:20:15 www2 kernel: BIOS-provided physical RAM map:
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 0000000000000000 - 000000000009f800 
(usable)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 000000000009f800 - 00000000000a0000 
(reserved)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 00000000000f0000 - 0000000000100000 
(reserved)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 0000000000100000 - 000000007eff0000 
(usable)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 000000007eff0000 - 000000007eff3000 
(ACPI NVS)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 000000007eff3000 - 000000007f000000 
(ACPI data)
Dec 21 10:20:15 www2 kernel:  BIOS-e820: 00000000fec00000 - 0000000100000000 
(reserved)
Dec 21 10:20:15 www2 kernel: 1135MB HIGHMEM available.
Dec 21 10:20:15 www2 kernel: 896MB LOWMEM available.
Dec 21 10:20:15 www2 kernel: found SMP MP-table at 000f51e0
Dec 21 10:20:15 www2 kernel: hm, page 000f5000 reserved twice.
Dec 21 10:20:15 www2 syslog: klogd startup succeeded
Dec 21 10:20:15 www2 kernel: hm, page 000f6000 reserved twice.
Dec 21 10:20:15 www2 kernel: hm, page 000f0000 reserved twice.
Dec 21 10:20:15 www2 kernel: hm, page 000f1000 reserved twice.
Dec 21 10:20:15 www2 kernel: NX (Execute Disable) protection: active
Dec 21 10:20:15 www2 kernel: On node 0 totalpages: 520176
Dec 21 10:20:15 www2 kernel: zone(0): 4096 pages.
Dec 21 10:20:15 www2 kernel: zone(1): 225280 pages.
Dec 21 10:20:15 www2 kernel: zone(2): 290800 pages.
Dec 21 10:20:15 www2 kernel: ACPI: Searched entire block, no RSDP was found.
Dec 21 10:20:15 www2 kernel: ACPI: RSDP located at physical address c00f6bc0
Dec 21 10:20:15 www2 kernel: RSD PTR  v0 [GBT   ]
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff3000, 0x28): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: ACPI table found: RSDT v1 [GBT    AWRDACPI 
16944.11825]
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff3040, 0x24): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff3040, 0x74): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: ACPI table found: FACP v1 [GBT    AWRDACPI 
16944.11825]
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff6d80, 0x24): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff6d80, 0x68): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: ACPI table found: APIC v1 [GBT    AWRDACPI 
16944.11825]
Dec 21 10:20:15 www2 kernel: __va_range(0x7eff6d80, 0x68): idx=33 mapped at 
fffdd000
Dec 21 10:20:15 www2 kernel: LAPIC (acpi_id[0x0000] id[0x0] enabled[1])
Dec 21 10:20:15 www2 kernel: CPU 0 (0x0000) enabledProcessor #0 Unknown CPU 
[15:4] APIC version 20
Dec 21 10:20:15 www2 kernel: 
Dec 21 10:20:15 www2 kernel: LAPIC (acpi_id[0x0001] id[0x1] enabled[1])
Dec 21 10:20:15 www2 kernel: CPU 1 (0x0100) enabledProcessor #1 Unknown CPU 
[15:4] APIC version 20
Dec 21 10:20:15 www2 kernel: 
Dec 21 10:20:15 www2 kernel: IOAPIC (id[0x2] address[0xfec00000] global_irq_base
[0x0])
Dec 21 10:20:15 www2 kernel: INT_SRC_OVR (bus[0] irq[0x0] global_irq[0x2] 
polarity[0x0] trigger[0x0])
Dec 21 10:20:15 www2 kernel: INT_SRC_OVR (bus[0] irq[0x9] global_irq[0x9] 
polarity[0x1] trigger[0x3])
Dec 21 10:20:15 www2 kernel: LAPIC_NMI (acpi_id[0x0000] polarity[0x0] trigger
[0x0] lint[0x1])
Dec 21 10:20:15 www2 kernel: LAPIC_NMI (acpi_id[0x0001] polarity[0x0] trigger
[0x0] lint[0x1])
Dec 21 10:20:15 www2 irqbalance: irqbalance startup succeeded
Dec 21 10:20:15 www2 kernel: 2 CPUs total
Dec 21 10:20:15 www2 kernel: Local APIC address fee00000
Dec 21 10:20:15 www2 kernel: Enabling the CPU's according to the ACPI table
Dec 21 10:20:15 www2 kernel: Intel MultiProcessor Specification v1.4
Dec 21 10:20:15 www2 kernel:     Virtual Wire compatibility mode.
Dec 21 10:20:15 www2 kernel: OEM ID: OEM00000 Product ID: PROD00000000 APIC at: 
0xFEE00000
Dec 21 10:20:15 www2 kernel: I/O APIC #2 Version 17 at 0xFEC00000.
Dec 21 10:20:15 www2 kernel: Processors: 2
Dec 21 10:20:15 www2 kernel: xAPIC support is present
Dec 21 10:20:15 www2 kernel: Enabling APIC mode: Flat.	Using 1 I/O APICs
Dec 21 10:20:15 www2 kernel: Kernel command line: ro root=/dev/hda2
Dec 21 10:20:15 www2 kernel: Initializing CPU#0
Dec 21 10:20:15 www2 kernel: Detected 3000.198 MHz processor.
Dec 21 10:20:15 www2 kernel: Console: colour VGA+ 80x25
Dec 21 10:20:15 www2 kernel: Calibrating delay loop... 5989.99 BogoMIPS
Dec 21 10:20:15 www2 kernel: Page-cache hash table entries: 524288 (order: 9, 
2048 KB)
Dec 21 10:20:15 www2 kernel: Page-pin hash table entries: 131072 (order: 7, 512 
KB)
Dec 21 10:20:15 www2 kernel: Dentry cache hash table entries: 262144 (order: 9, 
2048 KB)
Dec 21 10:20:15 www2 kernel: Inode cache hash table entries: 131072 (order: 8, 
1024 KB)
Dec 21 10:20:15 www2 kernel: Buffer cache hash table entries: 131072 (order: 7, 
512 KB)
Dec 21 10:20:15 www2 kernel: Memory: 2034464k/2080704k available (1718k kernel 
code, 41628k reserved, 1300k data, 232k init, 1163200k highmem)
Dec 21 10:20:15 www2 kernel: Mount cache hash table entries: 512 (order: 0, 
4096 bytes)
Dec 21 10:20:15 www2 kernel: CPU: Trace cache: 12K uops<6>CPU: L2 cache: 1024K
Dec 21 10:20:15 www2 kernel: CPU: Physical Processor ID: 0
Dec 21 10:20:15 www2 kernel: Intel machine check architecture supported.
Dec 21 10:20:15 www2 kernel: Intel machine check reporting enabled on CPU#0.
Dec 21 10:20:15 www2 kernel: Enabling fast FPU save and restore... done.
Dec 21 10:20:15 www2 kernel: Enabling unmasked SIMD FPU exception support... 
done.
Dec 21 10:20:15 www2 kernel: Checking 'hlt' instruction... OK.
Dec 21 10:20:15 www2 kernel: POSIX conformance testing by UNIFIX
Dec 21 10:20:15 www2 portmap: portmap startup succeeded
Dec 21 10:20:15 www2 kernel: mtrr: v1.40 (20010327) Richard Gooch 
(rgooch@atnf.csiro.au)
Dec 21 10:20:15 www2 kernel: mtrr: detected mtrr type: Intel
Dec 21 10:20:15 www2 kernel: CPU: Trace cache: 12K uops<6>CPU: L2 cache: 1024K
Dec 21 10:20:15 www2 kernel: CPU: Physical Processor ID: 0
Dec 21 10:20:15 www2 kernel: Intel machine check reporting enabled on CPU#0.
Dec 21 10:20:15 www2 kernel: CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 01
Dec 21 10:20:15 www2 kernel: per-CPU timeslice cutoff: 2925.02 usecs.
Dec 21 10:20:15 www2 kernel: task migration cache decay timeout: 10 msecs.
Dec 21 10:20:15 www2 kernel: enabled ExtINT on CPU#0
Dec 21 10:20:15 www2 kernel: ESR value before enabling vector: 00000000
Dec 21 10:20:15 www2 kernel: ESR value after enabling vector: 00000000
Dec 21 10:20:15 www2 kernel: Booting processor 1/1 eip 2000
Dec 21 10:20:15 www2 kernel: Initializing CPU#1
Dec 21 10:20:15 www2 kernel: masked ExtINT on CPU#1
Dec 21 10:20:15 www2 kernel: ESR value before enabling vector: 00000000
Dec 21 10:20:15 www2 kernel: ESR value after enabling vector: 00000000
Dec 21 10:20:15 www2 kernel: Calibrating delay loop... 5989.99 BogoMIPS
Dec 21 10:20:15 www2 kernel: CPU: Trace cache: 12K uops<6>CPU: L2 cache: 1024K
Dec 21 10:20:15 www2 kernel: CPU: Physical Processor ID: 0
Dec 21 10:20:15 www2 kernel: Intel machine check reporting enabled on CPU#1.
Dec 21 10:20:15 www2 kernel: CPU1: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 01
Dec 21 10:20:15 www2 kernel: Total of 2 processors activated (11979.98 
BogoMIPS).
Dec 21 10:20:15 www2 kernel: ENABLING IO-APIC IRQs
Dec 21 10:20:15 www2 kernel: Setting 2 in the phys_id_present_map
Dec 21 10:20:15 www2 kernel: ...changing IO-APIC physical APIC ID to 2 ... ok.
Dec 21 10:20:15 www2 kernel: ..TIMER: vector=0x31 pin1=2 pin2=0
Dec 21 10:20:15 www2 kernel: testing the IO APIC.......................
Dec 21 10:20:15 www2 kernel: 
Dec 21 10:20:15 www2 random: Initializing random number generator:  succeeded
Dec 21 10:20:15 www2 kernel: .................................... done.
Dec 21 10:20:15 www2 kernel: Using local APIC timer interrupts.
Dec 21 10:20:15 www2 kernel: calibrating APIC timer ...
Dec 21 10:20:15 www2 kernel: ..... CPU clock speed is 3000.1058 MHz.
Dec 21 10:20:15 www2 kernel: ..... host bus clock speed is 200.0068 MHz.
Dec 21 10:20:15 www2 kernel: cpu: 0, clocks: 2000068, slice: 666689
Dec 21 10:20:15 www2 kernel: CPU0<T0:2000064,T1:1333360,D:15,S:666689,C:2000068>
Dec 21 10:20:15 www2 kernel: cpu: 1, clocks: 2000068, slice: 666689
Dec 21 10:20:15 www2 kernel: CPU1<T0:2000064,T1:666672,D:14,S:666689,C:2000068>
Dec 21 10:20:15 www2 kernel: cpu_sibling_map[0] = 1
Dec 21 10:20:15 www2 kernel: cpu_sibling_map[1] = 0
Dec 21 10:20:15 www2 kernel: mapping CPU#0's runqueue to CPU#1's runqueue.
Dec 21 10:20:15 www2 kernel: zapping low mappings.
Dec 21 10:20:15 www2 kernel: Process timing init...done.
Dec 21 10:20:15 www2 kernel: Starting migration thread for cpu 0
Dec 21 10:20:15 www2 kernel: Starting migration thread for cpu 1
Dec 21 10:20:15 www2 kernel: PCI: PCI BIOS revision 2.10 entry at 0xfb290, last 
bus=1
Dec 21 10:20:15 www2 kernel: PCI: Using configuration type 1
Dec 21 10:20:15 www2 kernel: PCI: Probing PCI hardware
Dec 21 10:20:15 www2 kernel: PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Dec 21 10:20:15 www2 kernel: Transparent bridge - Intel Corp. 82801BA/CA/DB/EB 
PCI Bridge
Dec 21 10:20:15 www2 kernel: PCI: Using IRQ router PIIX [8086/24d0] at 00:1f.0
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I2,P0) -> 16
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I29,P0) -> 16
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I29,P1) -> 19
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I29,P2) -> 18
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I29,P0) -> 16
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I29,P3) -> 23
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I31,P0) -> 16
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B0,I31,P1) -> 17
Dec 21 10:20:15 www2 kernel: PCI->APIC IRQ transform: (B1,I9,P0) -> 20
Dec 21 10:20:15 www2 kernel: isapnp: Scanning for PnP cards...
Dec 21 10:20:15 www2 kernel: isapnp: No Plug & Play device found
Dec 21 10:20:15 www2 kernel: Linux NET4.0 for Linux 2.4
Dec 21 10:20:15 www2 kernel: Based upon Swansea University Computer Society 
NET3.039
Dec 21 10:20:15 www2 kernel: Initializing RT netlink socket
Dec 21 10:20:15 www2 kernel: apm: BIOS version 1.2 Flags 0x07 (Driver version 
1.16)
Dec 21 10:20:15 www2 kernel: apm: disabled - APM is not SMP safe.
Dec 21 10:20:15 www2 kernel: Total HugeTLB memory allocated, 0
Dec 21 10:20:15 www2 kernel: Starting kswapd
Dec 21 10:20:15 www2 kernel: allocated 32 pages and 32 bhs reserved for the 
highmem bounces
Dec 21 10:20:15 www2 kernel: VFS: Disk quotas vdquot_6.5.1
Dec 21 10:20:15 www2 kernel: aio_setup: num_physpages = 130044
Dec 21 10:20:15 www2 kernel: aio_setup: sizeof(struct page) = 60
Dec 21 10:20:15 www2 kernel: Hugetlbfs mounted.
Dec 21 10:20:15 www2 kernel: Detected PS/2 Mouse Port.
Dec 21 10:20:15 www2 kernel: pty: 2048 Unix98 ptys configured
Dec 21 10:20:15 www2 kernel: Serial driver version 5.05c (2001-07-08) with 
MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
Dec 21 10:20:15 www2 kernel: ttyS0 at 0x03f8 (irq = 4) is a 16550A
Dec 21 10:20:15 www2 kernel: ttyS1 at 0x02f8 (irq = 3) is a 16550A
Dec 21 10:20:15 www2 kernel: Real Time Clock Driver v1.10e
Dec 21 10:20:15 www2 kernel: NET4: Frame Diverter 0.46
Dec 21 10:20:15 www2 kernel: RAMDISK driver initialized: 256 RAM disks of 8192K 
size 1024 blocksize
Dec 21 10:20:15 www2 kernel: Uniform Multi-Platform E-IDE driver Revision: 
7.00beta4-2.4
Dec 21 10:20:15 www2 kernel: ide: Assuming 33MHz system bus speed for PIO 
modes; override with idebus=xx
Dec 21 10:20:15 www2 kernel: ICH5: IDE controller at PCI slot 00:1f.1
Dec 21 10:20:15 www2 kernel: ICH5: chipset revision 2
Dec 21 10:20:15 www2 kernel: ICH5: not 100% native mode: will probe irqs later
Dec 21 10:20:15 www2 kernel:     ide0: BM-DMA at 0xf000-0xf007, BIOS settings: 
hda:DMA, hdb:DMA
Dec 21 10:20:15 www2 kernel:     ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: 
hdc:pio, hdd:pio
Dec 21 10:20:15 www2 kernel: hda: ST3120022A, ATA DISK drive
Dec 21 10:20:15 www2 kernel: hdb: ST3120022A, ATA DISK drive
Dec 21 10:20:15 www2 kernel: blk: queue c050f1c0, I/O limit 4095Mb (mask 
0xffffffff)
Dec 21 10:20:15 www2 kernel: blk: queue c050f344, I/O limit 4095Mb (mask 
0xffffffff)
Dec 21 10:20:15 www2 kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Dec 21 10:20:15 www2 kernel: hda: attached ide-disk driver.
Dec 21 10:20:16 www2 kernel: hda: host protected area => 1
Dec 21 10:20:16 www2 kernel: hda: setmax_ext LBA 234441648, native  234439535
Dec 21 10:20:16 www2 kernel: hda: 234439535 sectors (120033 MB) w/2048KiB 
Cache, CHS=14593/255/63, UDMA(100)
Dec 21 10:20:16 www2 kernel: hdb: attached ide-disk driver.
Dec 21 10:20:16 www2 kernel: hdb: host protected area => 1
Dec 21 10:20:16 www2 kernel: hdb: 234441648 sectors (120034 MB) w/2048KiB 
Cache, CHS=14593/255/63, UDMA(100)
Dec 21 10:20:16 www2 kernel: ide-floppy driver 0.99.newide
Dec 21 10:20:16 www2 kernel: Partition check:
Dec 21 10:20:16 www2 kernel:  hda: hda1 hda2 hda3 hda4
Dec 21 10:20:16 www2 kernel:  hdb: hdb1
Dec 21 10:20:16 www2 kernel: ide-floppy driver 0.99.newide
Dec 21 10:20:16 www2 kernel: md: md driver 0.90.0 MAX_MD_DEVS=256, 
MD_SB_DISKS=27
Dec 21 10:20:16 www2 kernel: md: Autodetecting RAID arrays.
Dec 21 10:20:16 www2 kernel: md: autorun ...
Dec 21 10:20:16 www2 kernel: md: ... autorun DONE.
Dec 21 10:20:16 www2 kernel: pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Dec 21 10:20:16 www2 kernel: Initializing Cryptographic API
Dec 21 10:20:16 www2 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Dec 21 10:20:16 www2 kernel: IP: routing cache hash table of 16384 buckets, 
128Kbytes
Dec 21 10:20:16 www2 kernel: TCP: Hash tables configured (established 524288 
bind 65536)
Dec 21 10:20:16 www2 kernel: Linux IP multicast router 0.06 plus PIM-SM
Dec 21 10:20:16 www2 kernel: Initializing IPsec netlink socket
Dec 21 10:20:16 www2 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Dec 21 10:20:16 www2 kernel: RAMDISK: Compressed image found at block 0
Dec 21 10:20:16 www2 kernel: Freeing initrd memory: 369k freed
Dec 21 10:20:16 www2 kernel: VFS: Mounted root (ext2 filesystem).
Dec 21 10:20:17 www2 kernel: SCSI subsystem driver Revision: 1.00
Dec 21 10:20:17 www2 kernel: 3ware Storage Controller device driver for Linux 
v1.02.00.037.
Dec 21 10:20:17 www2 kernel: 3w-xxxx: No cards found.
Dec 21 10:20:17 www2 kernel: Journalled Block Device driver loaded
Dec 21 10:20:17 www2 kernel: sk98lin: Network Device Driver v8.13.1.3
Dec 21 10:20:17 www2 kernel: (C)Copyright 1999-2005 Marvell(R).
Dec 21 10:20:18 www2 kernel: eth0: Yukon Gigabit Ethernet 10/100/1000Base-T 
Adapter
Dec 21 10:20:18 www2 kernel:       PrefPort:A  RlmtMode:Check Link State
Dec 21 10:20:18 www2 kernel: kjournald starting.  Commit interval 5 seconds
Dec 21 10:20:18 www2 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Dec 21 10:20:18 www2 kernel: Freeing unused kernel memory: 232k freed
Dec 21 10:20:18 www2 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), 
internal journal
Dec 21 10:20:18 www2 kernel: Adding Swap: 1959920k swap-space (priority -1)
Dec 21 10:20:18 www2 kernel: kjournald starting.  Commit interval 5 seconds
Dec 21 10:20:18 www2 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), 
internal journal
Dec 21 10:20:18 www2 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Dec 21 10:20:18 www2 kernel: kjournald starting.  Commit interval 5 seconds
Dec 21 10:20:18 www2 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,3), 
internal journal
Dec 21 10:20:18 www2 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Dec 21 10:20:18 www2 kernel: IA-32 Microcode Update Driver: v1.13 
<tigran@veritas.com>
Dec 21 10:19:48 www2 rc.sysinit: Remounting root filesystem in read-write 
mode:  succeeded 
Dec 21 10:20:19 www2 kernel: microcode: No suitable data for cpu 1
Dec 21 10:19:48 www2 rc.sysinit: Activating swap partitions:  succeeded 
Dec 21 10:19:51 www2 rc.sysinit: Finding module dependencies:  succeeded 
Dec 21 10:20:19 www2 kernel: microcode: No suitable data for cpu 0
Dec 21 10:19:51 www2 devlabel: devlabel's temporary ignore 
list /etc/sysconfig/devlabel.d/ignore_list has been emptied due to a change in 
device configuration. 
Dec 21 10:20:19 www2 kernel: parport0: PC-style at 0x378 [PCSPP,EPP]
Dec 21 10:20:19 www2 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 21 10:19:51 www2 devlabel: devlabel service started/restarted 
Dec 21 10:20:19 www2 kernel: ip_conntrack version 2.1 (8192 buckets, 65536 
max) - 304 bytes per conntrack
Dec 21 10:19:51 www2 fsck: /dev/hda1: clean, 59/26104 files, 27981/104391 
blocks 
Dec 21 10:19:51 www2 fsck: /dev/hda3: clean, 2545/2932736 files, 319061/5859708 
blocks 
Dec 21 10:20:19 www2 kernel: eth0: network connection up using port A
Dec 21 10:19:51 www2 rc.sysinit: Checking filesystems succeeded 
Dec 21 10:20:19 www2 kernel:     speed:           100
Dec 21 10:19:52 www2 rc.sysinit: Mounting local filesystems:  succeeded 
Dec 21 10:20:19 www2 kernel:     autonegotiation: yes
Dec 21 10:19:52 www2 rc.sysinit: Enabling local filesystem quotas:  succeeded 
Dec 21 10:20:19 www2 kernel:     duplex mode:     full
Dec 21 10:19:53 www2 rc.sysinit: Enabling swap space:  succeeded 
Dec 21 10:20:19 www2 kernel:     flowctrl:        symmetric
Dec 21 10:19:54 www2 init: Entering runlevel: 3 
Dec 21 10:19:55 www2 microcode_ctl: microcode_ctl startup succeeded 
Dec 21 10:20:19 www2 kernel:     irq moderation:  disabled
Dec 21 10:20:19 www2 kernel:     scatter-gather:  enabled
Dec 21 10:19:55 www2 sysstat: Calling the system activity data collector 
(sadc):  
Dec 21 10:20:19 www2 kernel:     tx-checksum:     enabled
Dec 21 10:20:19 www2 sendmail: sendmail startup succeeded
Dec 21 10:19:55 www2 sysstat:  
Dec 21 10:20:19 www2 kernel:     rx-checksum:     enabled
Dec 21 10:19:55 www2 rc: Starting sysstat:  succeeded 
Dec 21 10:20:12 www2 kudzu:  succeeded 
Dec 21 10:20:12 www2 kudzu: Updating /etc/fstab succeeded 
Dec 21 10:20:12 www2 iptables:  succeeded 
Dec 21 10:20:12 www2 sysctl: net.ipv4.ip_forward = 0 
Dec 21 10:20:12 www2 sysctl: net.ipv4.conf.default.rp_filter = 1 
Dec 21 10:20:12 www2 sysctl: kernel.sysrq = 0 
Dec 21 10:20:12 www2 sysctl: kernel.core_uses_pid = 1 
Dec 21 10:20:12 www2 sysctl: kernel.shmmax = 134217728 
Dec 21 10:20:12 www2 network: Setting network parameters:  succeeded 
Dec 21 10:20:12 www2 network: Bringing up loopback interface:  succeeded 
Dec 21 10:20:14 www2 network: Bringing up interface eth0:  succeeded 
Comment 11 Lon Hohberger 2006-01-04 14:58:36 EST
*** Bug 168665 has been marked as a duplicate of this bug. ***
Comment 13 Ernie Petrides 2006-05-10 16:07:21 EDT
RHEL3 is now closed.
Comment 14 junichi NAKANO 2006-05-22 22:08:11 EDT
Is RHEL4 OK? 
Comment 15 Björn Augustsson 2006-05-23 06:35:08 EDT
> Is RHEL4 OK? 

Probably, I haven't seen it there on any out of ca 50 machines.

Then again, it only happened to two of ca 30 rhel3 ones, and only once
on one of them...

/August.
Comment 17 Ernie Petrides 2006-06-29 17:18:19 EDT
Closing as WORKSFORME based on work-around described in comment #16.
Comment 18 Björn Augustsson 2006-06-30 07:59:28 EDT
Uh, I can't see comment #16.

I see #15 (me believing it works on rhel4), and then #17 ("Closing, based on #16)

What's up?

/August.
Comment 19 Jeff Layton 2006-06-30 09:02:31 EDT
Sorry, that's a private comment, and has some customer specific info such that I
can't make it public. The gist of the comment is this:


The problem has been resolved after changing the MTU size on the loop back
interface to 8000.

If you're having this issue, please try that and let us know if that works for
you as well...
Comment 20 Björn Augustsson 2006-06-30 09:08:20 EDT
I'm having the issue, I'm the original reporter. (New mail address though)

I think it might work, I believe the smallest the "usable size" 
have ever been is 8033.

/August.

Note You need to log in before you can comment on or make changes to this bug.