Bug 155951 - /usr/lib64/libldap_r.so.2.0.130 does not contain correct dependencies.
/usr/lib64/libldap_r.so.2.0.130 does not contain correct dependencies.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-25 21:00 EDT by Dennis
Modified: 2015-01-07 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 04:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis 2005-04-25 21:00:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
Bug item 149043 is now also confirmed to exist on Red Hat EL 4 x86_64.

The 64-bit /usr/lib64/libldap_r.so.2.0.130 library does NOT contain
the correct dependencies.

The 32-bit /usr/lib/libldap_r.so.2.0.130 library on the other hand
does contain the correct dependencies.

I reported the Fedora Core 3 bug back in early Febuary and have
received no reply. This bug (especially now on Red Hat EL4) effects us
and our customers greatly.

We consider this an "extremely high severity" issue. 

Dennis.

Version-Release number of selected component (if applicable):
compat-openldap-2.1.30-2

How reproducible:
Always

Steps to Reproduce:
# readelf -a /usr/lib64/libldap_r.so.2.0.130 | grep NEEDED

  

Actual Results:  ... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libc.so.6]

Expected Results:   0x00000001 (NEEDED)                     Shared library: [liblber-2.2.so.7]
 0x00000001 (NEEDED)                     Shared library: [libresolv.so.2]
 0x00000001 (NEEDED)                     Shared library: [libdl.so.2]
 0x00000001 (NEEDED)                     Shared library: [libsasl2.so.2]
 0x00000001 (NEEDED)                     Shared library: [libssl.so.4]
 0x00000001 (NEEDED)                     Shared library: [libcrypto.so.4]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]


Additional info:

The supplied 32-bit library does contain the correct dependencies

The 32-bit library is correct.

# readelf -a /usr/lib/libldap_r.so.2.0.130 | grep NEEDED

... Shared library: [liblber-2.2.so.7]
... Shared library: [libresolv.so.2]
... Shared library: [libdl.so.2]
... Shared library: [libsasl2.so.2]
... Shared library: [libssl.so.4]
... Shared library: [libcrypto.so.4]
... Shared library: [libc.so.6]
Comment 1 Suzanne Hillman 2005-04-26 12:00:19 EDT
If this is a high urgency thing, please contact support by going to
http://www.redhat.com/support or calling 800-REDHAT1
Comment 2 Dennis 2005-04-26 23:10:24 EDT
I carried out more testing and it does appear that the 64-bit
libldap_r.so.2.0.130 is useable under Red Hat EL4 whilst it
is not under FC3.

Under Fc3 (x86_64) our application fails with the following 
message

> Unable to load library 'libAceLdap.so': /usr/lib64/libldap_r.so.2:
> undefined symbol: SSL_CTX_set_tmp_rsa_callback.

That problem does not occur under RHEL4 (x86_64). The md5sums
of the /usr/lib65/libldap_r.so.2.0.130 are the same on Fc3 and RHEL4.

It must be another issue under FC3 (ld.so.cache??). Confusing.
The built in dependencies appears to be a red herring.

Apologies for the false alarm. Please close this bug item as it
is not a problem under RHEL4. I will update the FC3 bug item with
the extra information.

Thanks.

Dennis

Comment 3 Dennis 2005-04-26 23:36:31 EDT
I now know what is going on here.

Our application was compiled on Red Hat EL3. This build
fails to load up the sub-dependencies of /usr/lib64/libldap_r.so.2.0.130
when run on FC3.

We have now started building our application on Red Hat EL4. This build
does work with respect to loading up the sub-dependencies 
of /usr/lib64/libldap_r.so.2.0.130 on FC3.

I believe the problem relates to our build. This problem was disguised
when run on Red Hat 3 (due to exact library matches build & run). 
However, when run on a installation where the run libraries differ
from the build libraries then we run into trouble.

Apologies for taking up your time. Problem solved.

Thanks

Dennis.
Comment 4 Jay Turner 2005-04-27 04:00:25 EDT
Closing out this issue, as all appears to be well now.

Note You need to log in before you can comment on or make changes to this bug.