This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 156086 - ctrl-c exits R session in sesh when run using sudo with selinux enabled
ctrl-c exits R session in sesh when run using sudo with selinux enabled
Status: CLOSED DUPLICATE of bug 156085
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-27 09:16 EDT by Marc Schwartz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 09:19:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Schwartz 2005-04-27 09:16:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
When running R (http://www.r-project.org/) version 2.1.0 in a console using 'sudo R', ctrl-c will exit R and return to the console command line, however leaving an R process running. This has been replicated with at least one prior R version as well.

It appears that R is run in sesh in this situation. Presumably, ctrl-c kills sesh, but does not kill R.

A bug was filed in the R bug tracking system:

http://r-bugs.biostat.ku.dk/cgi-bin/R/incoming?id=7819;user=guest;selectid=7819

However this appears to be related to using "sudo R" when SELinux is enabled, as the ctrl-c behavior does not occur when SELinux is disabled.

Relevant output from "ps -aux" shows:

root     12272 49.2  0.8 23108 16924 ?       R    07:45   2:07 /usr/local/lib/R/bin/exec/R
root     15503  0.0  0.0  2556  252 pts/1    S+   07:46   0:00 sesh /usr/local/bin/R
root     15626  0.5  0.8 23204 16920 pts/1   S+   07:46   0:00 /usr/local/lib/R/bin/exec/R

The first R session is what remains from the prior ctrl-c event.

Relevant content from /etc/sudoers is:

marcs   ALL=(ALL) ALL


Version-Release number of selected component (if applicable):
sudo-1.6.7p5-30.1

How reproducible:
Always

Steps to Reproduce:
With SELinux enabled:

1. Run "sudo R" from a terminal emulator
2. Enter password
3. R loads
4. Press ctrl-c once at the R prompt


Actual Results:  It appears that sesh is killed, exiting the R session. However an R process remains.


Expected Results:  Presumably ctrl-c should not kill sesh and the R session


Additional info:
Comment 1 Thomas Woerner 2005-04-27 09:19:55 EDT

*** This bug has been marked as a duplicate of 156085 ***

Note You need to log in before you can comment on or make changes to this bug.