Bug 156087 - php srpm fails to build
php srpm fails to build
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-27 09:26 EDT by Christoph Franke
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 11:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Franke 2005-04-27 09:26:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
I tried to build php out of the php-4.3.11-2.4.src.rpm on FC3, but it keeps failing with different errors. While configure runs fine, make stops with different errors. Will post my last three runs.

1. run

libtool: link: `ext/standard/dns.lo' is not a valid libtool object
make: *** [sapi/cgi/php] Error 1
make: *** Waiting for unfinished jobs....
Fehler: Bad exit status from /var/tmp/rpm-tmp.40179 (%build)

2. run

/bin/sh /usr/src/redhat/BUILD/php-4.3.11/build-cgi/libtool --silent --preserve-dup-deps --mode=compile gcc -I/usr/src/redhat/BUILD/php-4.3.11/ext/bcmath/libbcmath/src -Iext/bcmath/ -I/usr/src/redhat/BUILD/php-4.3.11/ext/bcmath/ -DPHP_ATOM_INC -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/include -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/main -I/usr/src/redhat/BUILD/php-4.3.11 -I/usr/kerberos/include -I/usr/include/libxml2 -I/usr/include/freetype2 -I/usr/include/imap -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/mbregex -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/libmbfl -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/include/ncurses -I/usr/include/pcre -I/usr/include/pspell -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/TSRM -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/Zend -I/usr/src/redhat/BUILD/php-4.3.11/main -I/usr/src/redhat/BUILD/php-4.3.11/Zend -I/usr/src/redhat/BUILD/php-4.3.11/TSRM -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/    -O2 -g -pipe -m64 -Wall -fno-strict-aliasing  -prefer-non-pic -c /usr/src/redhat/BUILD/php-4.3.11/ext/bcmath/libbcmath/src/debug.c -o ext/bcmath/libbcmath/src/debug.o
Usage: ld.so [OPTION]... EXECUTABLE-FILE [ARGS-FOR-PROGRAM...]
You have invoked `ld.so', the helper program for shared library executables.
This program usually lives in the file `/lib/ld.so', and special directives
in executable files using ELF shared libraries tell the system's program
loader to load the helper program from this file.  This helper program loads
the shared libraries needed by the program executable, prepares the program
to run, and runs it.  You may invoke this helper program directly from the
command line to load and run an ELF executable file; this is like executing
that file itself, but always uses this helper program from the file you
specified, instead of the helper program file specified in the executable
file you run.  This is mostly of use for maintainers to test new versions
of this helper program; chances are you did not intend to run this program.

  --list                list all dependencies and how they are resolved
  --verify              verify that given object really is a dynamically linked
                        object we can handle
  --library-path PATH   use given PATH instead of content of the environment
                        variable LD_LIBRARY_PATH
  --inhibit-rpath LIST  ignore RUNPATH and RPATH information in object names
                        in LIST
gcc: : No such file or directory
In file included from /usr/src/redhat/BUILD/php-4.3.11/ext/bcmath/libbcmath/src/bcmath.h:59,
                 from /usr/src/redhat/BUILD/php-4.3.11/ext/bcmath/libbcmath/src/debug.c:38:
/usr/src/redhat/BUILD/php-4.3.11/main/php.h:393:30: tsrm_virtual_cwd.h: No such file or directory
make: *** [ext/bcmath/libbcmath/src/debug.lo] Error 1
make: *** Waiting for unfinished jobs....
Fehler: Bad exit status from /var/tmp/rpm-tmp.76902 (%build)

3. run

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.76902 (%build)

/bin/sh /usr/src/redhat/BUILD/php-4.3.11/build-cgi/libtool --silent --preserve-dup-deps --mode=compile gcc  -DHAVE_CONFIG_H -Iext/mbstring/ -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/ -DPHP_ATOM_INC -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/include -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/main -I/usr/src/redhat/BUILD/php-4.3.11 -I/usr/kerberos/include -I/usr/include/libxml2 -I/usr/include/freetype2 -I/usr/include/imap -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/mbregex -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/libmbfl -I/usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/include/ncurses -I/usr/include/pcre -I/usr/include/pspell -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/TSRM -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/Zend -I/usr/src/redhat/BUILD/php-4.3.11/main -I/usr/src/redhat/BUILD/php-4.3.11/Zend -I/usr/src/redhat/BUILD/php-4.3.11/TSRM -I/usr/src/redhat/BUILD/php-4.3.11/build-cgi/    -O2 -g -pipe -m64 -Wall -fno-strict-aliasing  -prefer-pic -c /usr/src/redhat/BUILD/php-4.3.11/ext/mbstring/libmbfl/mbfl/mbfl_filter_output.c -o ext/mbstring/libmbfl/mbfl/mbfl_filter_output.lo
Usage: ld.so [OPTION]... EXECUTABLE-FILE [ARGS-FOR-PROGRAM...]
You have invoked `ld.so', the helper program for shared library executables.
This program usually lives in the file `/lib/ld.so', and special directives
in executable files using ELF shared libraries tell the system's program
loader to load the helper program from this file.  This helper program loads
the shared libraries needed by the program executable, prepares the program
to run, and runs it.  You may invoke this helper program directly from the
command line to load and run an ELF executable file; this is like executing
that file itself, but always uses this helper program from the file you
specified, instead of the helper program file specified in the executable
file you run.  This is mostly of use for maintainers to test new versions
of this helper program; chances are you did not intend to run this program.

  --list                list all dependencies and how they are resolved
  --verify              verify that given object really is a dynamically linked
                        object we can handle
  --library-path PATH   use given PATH instead of content of the environment
                        variable LD_LIBRARY_PATH
  --inhibit-rpath LIST  ignore RUNPATH and RPATH information in object names
                        in LIST
gcc: : No such file or directory
make: *** [ext/mbstring/libmbfl/mbfl/mbfl_filter_output.lo] Error 1
make: *** Waiting for unfinished jobs....
Fehler: Bad exit status from /var/tmp/rpm-tmp.1321 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.1321 (%build)



Version-Release number of selected component (if applicable):
php-4.3.11-2.4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild php-4.3.11-2.4.src.rpm
2.
3.
  

Additional info:
Comment 1 Joe Orton 2005-04-27 11:02:40 EDT
What version of libtool do you have?
Comment 2 Christoph Franke 2005-04-27 11:18:06 EDT
rpm -qi libtool
Name        : libtool                      Relocations: (not relocatable)
Version     : 1.5.6                             Vendor: Red Hat, Inc.
Release     : 4.FC3.2                       Build Date: Di 15 Mär 2005 17:47:38 GMT
Install Date: Mi 27 Apr 2005 08:25:28 GMT      Build Host: dolly.build.redhat.com
Group       : Entwicklung/Tools             Source RPM:
libtool-1.5.6-4.FC3.2.src.rpm
Size        : 2461133                          License: GPL
Signature   : DSA/SHA1, Mi 13 Apr 2005 03:07:52 GMT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.gnu.org/software/libtool/
Comment 3 Joe Orton 2005-04-27 11:24:32 EDT
Then there is some more complicated problem here, please try
fedora-list@redhat.com for further help and re-open this bug if you work out
what the problem is.  (obviously, the package builds fine for me and in our
build system)

Note You need to log in before you can comment on or make changes to this bug.