Bug 1561181 - Major upgrade: OSP12 -> OSP13 upgrade of HA services
Summary: Major upgrade: OSP12 -> OSP13 upgrade of HA services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Damien Ciabrini
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-27 20:28 UTC by Damien Ciabrini
Modified: 2018-06-27 13:50 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 555713 None stable/queens: MERGED tripleo-heat-templates: Fix update of pacemaker container images during major upgrade (I85e11dd93c7fd2c42e71b467f46b0044... 2018-03-28 12:37:15 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:26 UTC

Description Damien Ciabrini 2018-03-27 20:28:00 UTC
Description of problem:

Implement major upgrade of HA services:
. bare metal Pike to containerized Queens
. containerized Pike to containerized Queens

Make sure container version are upgraded during the major upgrade tasks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Deploy OSP12
2. Upgrade to OSP13
3.


Expected results:
the Overcloud's upgrade_tasks taken from config download should succeed.

Additional info:
This bz gather bz for tripleo-heat-templates and puppet-tripleo

Comment 1 Damien Ciabrini 2018-03-27 20:29:49 UTC
Correction from description, this bz only requires a review in tripleo-heat-templates to be fixed.

Comment 5 errata-xmlrpc 2018-06-27 13:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.