Bug 156151 - adding no-chunks behavior to fedora-docs XSL
Summary: adding no-chunks behavior to fedora-docs XSL
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
(Show other bugs)
Version: devel
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Wade
QA Contact: Tammy Fox
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: fdp-toolchain-traqr
TreeView+ depends on / blocked
 
Reported: 2005-04-27 21:16 UTC by Karsten Wade
Modified: 2009-07-07 04:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 00:58:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated XSL for chunking HTML. (1.38 KB, text/plain)
2005-04-27 21:16 UTC, Karsten Wade
no flags Details
Updated XSL for no-chunks HTML (1.33 KB, text/xml)
2005-04-27 21:18 UTC, Karsten Wade
no flags Details
Updated master XSL for control over chunking in HTML (1.46 KB, text/xml)
2005-04-27 21:19 UTC, Karsten Wade
no flags Details
Makefile to support chunking in HTML (1.18 KB, text/plain)
2005-04-27 21:21 UTC, Karsten Wade
no flags Details

Description Karsten Wade 2005-04-27 21:16:10 UTC
From jlaska:

1) Creating ./xsl/main-html-one.xsl to support: 
         <xsl:param name="onechunk" select="1"/>

2) Adding the following xsl:output options to ./xsl/redhat.xsl:
       <!-- Generate UTF-8 html == only applies to the one chunk-->
       <xsl:output method="html"
                   encoding="UTF-8"
                   indent="no"/>

3) some Makefile options to allow chunked vs nochunks html generation

I've modified redhat.xsl, and replaced main-html.xsl with
main-html-nochunks.xsl and main-html-chunks.xsl.  The Makefile we use
has been modified to suite these changes as well.

## end jlaska quote

(attachments following)

Comment 1 Karsten Wade 2005-04-27 21:16:11 UTC
Created attachment 113740 [details]
Updated XSL for chunking HTML.

Comment 2 Karsten Wade 2005-04-27 21:18:33 UTC
Created attachment 113742 [details]
Updated XSL for no-chunks HTML

Comment 3 Karsten Wade 2005-04-27 21:19:50 UTC
Created attachment 113743 [details]
Updated master XSL for control over chunking in HTML

Comment 4 Karsten Wade 2005-04-27 21:21:24 UTC
Created attachment 113744 [details]
Makefile to support chunking in HTML

This Makefile is specific for QA docs, aiui

Comment 5 Karsten Wade 2005-05-29 19:47:37 UTC
Tommy:

I think the XSL is Oll Korrect here, but we need changes to the Makefile for the
release notes.  We need to have no chunking for the release notes.  Can you look
at merging what we need into the Makefile for the release notes?

We may suffer some regressions if we just push these XSL changes out, but we
need the changes before we can fully QA across the board.  If you can easily
make the changes to all Makefiles and load in the new XSL files, then announce
to the list and ask everyone to QA their own docs.

Let me know what you think.  I haven't put in the changes myself mainly because
of the QA for the Makefiles.  My make-fu is not very strong.

- Karsten

Comment 6 Tommy Reynolds 2005-05-29 21:33:40 UTC
I'll try to look at it tomorrow, 30 May 2005 but I'm travelling the rest of the
week w/o access to anything.

Comment 7 Karsten Wade 2005-05-30 19:00:54 UTC
I'm doing these merges right now to support a no-chunk relnotes for the release.
 Feeling more comfortable after hacking everything up this AM.

Comment 8 eric@christensenplace.us 2009-07-07 04:08:58 UTC
Ticket moved to allow products to be removed from BZ.


Note You need to log in before you can comment on or make changes to this bug.