Bug 156179 - Tape device created does not get displayed in iscsi-ls -l
Tape device created does not get displayed in iscsi-ls -l
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: AJ Lewis
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 04:39 EDT by Nitin Chandna
Modified: 2008-04-07 00:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 16:55:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nitin Chandna 2005-04-28 04:39:14 EDT
Description of problem:
Unable to find where the tape device is getting created(like /dev/st0 
or /dev/st1).
JBODs and other Storage Array luns are displayed in iscsi-ls -l as /dev/sdb 
or /dev/sdc with iscsi initiator 3.6.2.
Whereas in case of tape, nothing is mentioned. Though other details like 
Vendor, Capacity etc are getting displayed as an output for tape. It is 
recommended that this information about the precise device to do an I/O upon 
should be displayed for the tape as well.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Every time

Steps to Reproduce:
1. Configure a tape device inidividual lun on MDS 9216
2. Configure the DiscoveryAddress on linux host and start the driver
3. The tape device gets discovered but does not show the device which got 
created, for example: /dev/st0
  
Actual results:
The tape device gets discovered but does not show the device which got created, 
for example: /dev/st0

Expected results:
As an output of iscsi-ls -l, the actual device mapping which got created for 
tape should be displayed as well.

Additional info:
The output of iscsi-ls -l for a JBOD and a tape configured is as follows. JBOD 
is being shown as /dev/sdb, whereas the tape though has been mapped 
to /dev/st0, but iscsi-ls -l does not show this:

[root@linux-2 root]# iscsi-ls -l
*******************************************************************************
        SFNet iSCSI Driver Version ... 3.6.2 (27-Sep-2004 )
*******************************************************************************
TARGET NAME             : iqn.2004-04.com.cisco.cnitin-jbod-567c
TARGET ALIAS            : 
HOST NO                 : 2 
BUS NO                  : 0 
TARGET ID               : 4 
TARGET ADDRESS          : 10.1.1.80:3260
SESSION STATUS          : ESTABLISHED AT Wed Apr 27 16:52:50 2005
NO. OF PORTALS          : 1 
PORTAL ADDRESS 1        : 10.1.1.80:3260,12416
SESSION ID              : ISID 00023d000001 TSID 3080
 
DEVICE DETAILS :
-------------- 
LUN ID : 0
  Vendor: SEAGATE  Model: ST318452FC       Rev: 0004
  Type:   Direct-Access                    ANSI SCSI revision: 04
  page83 type3: 20000004cf8c567c
  page80: 334556303756455030303030373234314b484857
  Device: /dev/sdb
*******************************************************************************
TARGET NAME             : iqn.2004-04.com.cisco.vinuvgs-tape-lun2
TARGET ALIAS            : 
HOST NO                 : 2 
BUS NO                  : 0 
TARGET ID               : 18 
TARGET ADDRESS          : 10.1.1.80:3260
SESSION STATUS          : ESTABLISHED AT Wed Apr 27 16:52:50 2005
NO. OF PORTALS          : 1 
PORTAL ADDRESS 1        : 10.1.1.80:3260,12416
SESSION ID              : ISID 00023d000001 TSID 3080
 
DEVICE DETAILS :
-------------- 
LUN ID : 0
  Vendor: QUANTUM  Model: SuperDLT1        Rev: 2323
  Type:   Sequential-Access                ANSI SCSI revision: 04
*******************************************************************************
Comment 1 AJ Lewis 2005-05-04 15:46:20 EDT
The current method of detecting device names for scsi discs relies on the output
of /proc/partitions.  Is there a similar listing for st devices anywhere?
Comment 2 AJ Lewis 2005-05-04 16:55:06 EDT
After looking at a system with a scsi attached tape drive, I can find no way to
detect which device node it is attached to - there is no output in /proc and no
tools that can detect this.  Therefore, I am not planning on adding this ability
to iscsi-ls.
Comment 3 Nitin Chandna 2005-05-05 06:02:59 EDT
I am aware of one iscsi initiator for Solaris which does show this.
I needed this change since I am automating some test cases for the setup with 
our iscsi targets to run with RHEL initiator. Without this, it would be tough 
for my scripts to identify which tape device mapping I should be accessing.
Comment 4 AJ Lewis 2005-05-05 09:24:16 EDT
The issue isn't the initiator.  The initiator does not do device node
assignment.  The scsi mid-layer does device-node assignment - as far as I can
tell, there is no way to query that information from the kernel.

Note You need to log in before you can comment on or make changes to this bug.