This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 156180 - Montage labels not rendered
Montage labels not rendered
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 04:40 EDT by Samuli Kärkkäinen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 15:08:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Samuli Kärkkäinen 2005-04-28 04:40:43 EDT
With ImageMagick-6.2.2.0-1.fc3 command "montage -label a in1.jpg -label b
in2.jpg out.jpg" creates an image with no labels at all. With ImageMagick of the
previous FC3 update, every thumbnail had the last given label. Before that,
labels worked right.
Comment 1 Leonard Evens 2005-05-08 15:47:47 EDT
I've experienced the same problem.  I also tried adding a pointsize option in
addition to see if it made any difference, but it didn't.

In addition, the ImageMagick and component program man pages have very little
useful information.  You are instructed to do "progr_name" -help, which lists
the options but it otherwise not very helpful.  Info gives you the same
information as the web page.  Moreover, I couldn't find any information on the
ImageMagick webpage.

At least some other options like -flip still work.
Comment 2 Leonard Evens 2005-05-13 09:59:58 EDT
I've fiddled with the debug option and spent a little time looking at the code.
 I think montage may not be parsing the command line correctly and it may just
be losing the label.  But this is really just a guess.

I hope this problem will be addressed soon since I use montage regularly in my
workflow.
Comment 3 Leonard Evens 2005-05-17 10:06:11 EDT
The problem appears to be fixed in ImagageMagick 6.2.2.-4.  I downloaded and
installed the rpm package, which is indicated as being for Fedora Core 3.  the
only problem I encountered is that rpm seemed to think the current FC3 version
was newer although it wasn't, so I had to use the --oldpackage option.

I'm not sure why this is taking so long.
Comment 4 Matthias Clasen 2005-05-18 17:03:42 EDT
6.2.2-4 doesn't seem to fix the issue for me.
Comment 5 Leonard Evens 2005-05-18 19:20:08 EDT
I used the command
montage -label xxxx im1.jpg x.png
Then
display x.png
shows me im1.jpg with the label xxxx
It also works with my shell script which uses
montage -label %f *.jpg  /d/index/$1.png
$1 an argument to the script.  This takes all the files *.jpg in the current
directories, puts them in a montage file with file names as labels.

Just what goes wrong for you?

But

display -label name image_file

still doesn't add the label to the displayed image.  I don't know if it is
supposed to or not.
Comment 6 Matthew Miller 2006-07-10 16:55:27 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!

Note You need to log in before you can comment on or make changes to this bug.