Bug 156279 - RTF files display as blank documents
RTF files display as blank documents
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: Regression
Depends On:
Blocks: 156320 164274
  Show dependency treegraph
 
Reported: 2005-04-28 12:21 EDT by Stuart Winter
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-650
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 11:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 48600 None None None Never

  None (edit)
Description Stuart Winter 2005-04-28 12:21:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
openoffice.org-1.1.2-24.2.0.EL3.i386
openoffice.org-i18n-1.1.2-24.2.0.EL3.i386
openoffice.org-libs-1.1.2-24.2.0.EL3.i386
openoffice.org-style-gnome-1.1.0-16.9.EL.i386

I up2dated a RHEL3 box which installed the above.
Open Office now displays RTF files as blank documents.

I have reverted to the Open Office from RHEL3-U4 and the document contents are once again visible.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-24.2.0.EL3.i386

How reproducible:
Always

Steps to Reproduce:
1.Install this new version of open office
2.Load an RTF file (I can provide you with some if necessary)
3.See a blank document.
  

Actual Results:  Blank document.
The file properties inside Open Office reports that it is an RTF file and displays its file size correctly.

Expected Results:  See the document's contents.

Additional info:

This is a serious problem - especially for our sales people who use RTF a lot!
Comment 1 Caolan McNamara 2005-04-29 03:25:37 EDT
This doesn't sound good.
Comment 3 Dan Williams 2005-04-29 11:52:38 EDT
Stuart:  could you attach an RTF or forward it if necessary?
Comment 5 Dan Williams 2005-04-29 12:23:44 EDT
Stuart:

Using RHEL3 U4 and OOo version 1.1.2-24.2.0.EL3, I tried to open this file:

http://www.ccel.org/u/unknowing/cloud.RTF

It opens correctly, not blank.  Can you confirm that, and also attach your blank
document to this issue or email it to me directly?
Comment 6 Dan Williams 2005-04-29 12:41:54 EDT
caolan: The test doc from Stuart actually doesn't display in 2.0 either
(1.9.93-1).  Seems to be a > 1.1.0 problem, any chance you could take a look as
well?  Just forwarded it to you.
Comment 7 Caolan McNamara 2005-05-03 05:56:36 EDT
Submitted a fix for 2.0 as ooo#48600#
Comment 10 Dan Williams 2005-05-04 17:07:35 EDT
Fix integrated to pkgcvs, building RHEL4 test packages.
Comment 15 Dan Williams 2005-07-21 09:32:52 EDT
Confirmed fixed with openoffice.org-1.1.2-27.2.0.EL3
Comment 17 Stuart Winter 2005-08-24 05:28:56 EDT
Hi

Is it possible to have even a test version of openoffice?
This user is now on RHEL4 and still has this problem.

Thanks
Comment 18 Dan Williams 2005-08-24 09:27:53 EDT
stuart - http://dcbw.boston.redhat.com/ooo/
Comment 20 Red Hat Bugzilla 2005-09-28 11:36:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-650.html

Note You need to log in before you can comment on or make changes to this bug.