Bug 156286 - Kernel-2.6.11-1.14_FC3 shows segmentation fault when compiling and loading sk98lin for Mavell's Gigabit NIC
Kernel-2.6.11-1.14_FC3 shows segmentation fault when compiling and loading sk...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 12:52 EDT by Somin Lee
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 21:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Somin Lee 2005-04-28 12:52:20 EDT
Description of problem:
I am using Intel Server Platform SR1435VP2 (board is SE7320VP2) This system has 
two Gigabit Ethernet card. One of them is Intel chip, and another is Marvell 
Chip
When I first use kernel-2.6.9-1.667 in Fedora Core 3 CD, Marvell's NIC was not 
working. I downloaded driver from www.syskonnect.com
(http://www.syskonnect.com/syskonnect/support/driver/d0102_driver.html) and 
could build SE98lin module, and it worked well. But after I updated to Kernel-
2.6.11-1.14_FC3 from Fedora 3 updates, when I compiled the same source and 
newest source file from Syskonnect.com, it shows segmentation fault error and 
doing infinite loop.
-latest output lines -
Check kernel functions (Changed: nothing)                            [   OK   ]
Compile the kernel (done)                                            [   OK   ]
Copy driver man page into /usr/share/man/man4/ (done)                [   OK   ]
Check the driver                                                       
working./install.sh: line 1191:  4188 Segmentation fault      $insmod_bin ./
$drv_name.ko >>$logfile 2>&1

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
With Marvell's new chip 88E8050. I used Intel SR1435VP2

Steps to Reproduce:
1.With Marvell's new chip 88E8050
2.download driver from www.syskonnect.com
3.run "install.sh" in the driver installation files 
  
Actual results:
After compiling kernel and sk98lin.ko module, install scripts tried to load 
sk98lin module. At that moment, segmentation fault occurs.


Expected results:
1.Nomally sk98lin.ko module loaded
2.NIC starts to work, and status message for Marvell NIC shows in console
-When I succeeded on kernel-2.6.9, it shows speed, duplex, and other status 
information for Marvell NIC.

Additional info:
Comment 1 Warren Togami 2005-04-28 13:03:25 EDT
Why are you trying to build your own sk98lin?  The kernel is shipped with its
own sk98lin which works on many cards.  I have two different motherboards at
home where it is working great.

If the FC3 update sk98lin doesn't work, that is the real bug and it should be
filed at upstream bugzilla.kernel.org too.

If the vendor has fixes for the driver, they should communicate with kernel.org
developers so it becomes part of all Linux distributions.
Comment 2 Dave Jones 2005-04-28 21:10:41 EDT
Syskonnect problem.

Note You need to log in before you can comment on or make changes to this bug.