Bug 156335 - less only works when getting piped input
less only works when getting piped input
Status: CLOSED DUPLICATE of bug 156333
Product: Fedora Legacy
Classification: Retired
Component: less (Show other bugs)
rhl9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 20:15 EDT by Grant Mills
Modified: 2007-04-18 13:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 20:22:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant Mills 2005-04-28 20:15:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
less works fine when receiving input from a pipe:
      ls -alR / | less

when I try to access less' help I get this across the top of the screen, minus the quotes:
      "ESC]2;<host>:/home/<login>^GESC]1;<host>^G"
I get '~' starting each line all the down to the bottom and this along the bottom, again minus the quotes:
      "@/\less/\help/\file/\@ (file 2 of 2) (END)"

If I try to give less a file directly to display:
      less sometextfile.txt
The screen clears (terminal init stuff) and I get this at the bottom, again minus the quotes:
      "ESC]2;<host>:/home/<login>^GESC]1;<host>^G
       sometextfile.txt (END)"

Version-Release number of selected component (if applicable):
less-378-7.2.legacy

How reproducible:
Always

Steps to Reproduce:
1. Execute "ls -alR | less"
2. At the ":" Prompt, hit 'h' for help

  

Actual Results:  I get this across the top of the screen, minus the quotes:
      "ESC]2;<host>:/home/<login>^GESC]1;<host>^G"
I get '~' starting each line all the down to the bottom and this along the bottom, again minus the quotes:
      "@/\less/\help/\file/\@ (file 2 of 2) (END)"


Expected Results:  Less' help.  I can't remember if the help occurs in a whole or split screen, but I do recall seeing the key (or combos) along the left column with their description to the right.

Additional info:

 less --version
less 378+iso254   (Red Hat)
Copyright (C) 2002 Mark Nudelman

less comes with NO WARRANTY, to the extent permitted by law.
For information about the terms of redistribution,
see the file named README in the less distribution.
Homepage: http://www.greenwoodsoftware.com/less
Comment 1 Grant Mills 2005-04-28 20:22:15 EDT
Making duplicate.  I accidentally hit reload at the post_bug page.

*** This bug has been marked as a duplicate of 156333 ***

Note You need to log in before you can comment on or make changes to this bug.