Bug 156338 - bugzilla.redhat.com has an invalid XML DTD
bugzilla.redhat.com has an invalid XML DTD
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 20:36 EDT by Max Kanat-Alexander
Modified: 2007-04-18 13:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-30 06:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the DTD (430 bytes, patch)
2005-04-28 20:37 EDT, Max Kanat-Alexander
no flags Details | Diff

  None (edit)
Description Max Kanat-Alexander 2005-04-28 20:36:40 EDT
The bugzilla.dtd is invalid on bugzilla.redhat.com, because Red Hat has added
custom fields to Bugzilla. The fix is very simple, the fields just need to be
added to the DTD.

Having an invalid DTD makes strict XML parsers die when trying to parse the
output from xml.cgi. In particular, I'm running into trouble setting up a mozbot
for Fedora because the DTD is invalid.
Comment 1 Max Kanat-Alexander 2005-04-28 20:37:17 EDT
Created attachment 113815 [details]
Patch to the DTD

Here's a patch to bugzilla.dtd that should fix the problem.
Comment 2 David Lawrence 2005-04-29 13:01:48 EDT
Patch applied. Please verify the fix and close if satisfactory.
Comment 3 Max Kanat-Alexander 2005-04-30 06:09:08 EDT
Yeah, that seemed to fix it, along with my patch for another bug over at b.m.o.,
in the actual mozbot code.

The bot is cluebot on irc.freenode.net, if you ever want to come around and play
with it. It has a few nice features for interacting with Bugzilla.

Note You need to log in before you can comment on or make changes to this bug.