Bug 156349 - rhel-isa describes raidtools instead of mdadm
rhel-isa describes raidtools instead of mdadm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Don Domingo
ecs-bugs
http://www.redhat.com/docs/manuals/en...
: Documentation, Reopened
Depends On:
Blocks: 632028
  Show dependency treegraph
 
Reported: 2005-04-29 02:33 EDT by Richard Shedron
Modified: 2011-02-14 14:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 632028 (view as bug list)
Environment:
Last Closed: 2010-09-06 21:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Shedron 2005-04-29 02:33:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
rhel 4 no longer uses raidtools to configure and manage raid devices.  Instead, mdadm is included.  However, the rhel-isa description of how to do post-install raid creation and management refers only to raidtools.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Look at http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/admin-guide/s1-storage-rhlspec.html#S2-STORAGE-RAID-DAY2DAY
2. If you wish to see that the raidtools package is no longer included, read the release notes.
3.
  

Expected Results:  rhel-isa should describe how to use mdadm instead of raidtools.

Additional info:
Comment 1 Richard Shedron 2006-07-10 02:40:28 EDT
The documentation describes /etc/raidtab which was used by the tools in the
raidtools package and is not used by mdadm.  Also, the documentation describes
/sbin/mkraid and /sbin/raidhotadd which were part of the raidtools package. 
They are not part of the mdadm package.

/sbin/mdadm from the mdadm package is used in place of all of the tools from
raidtools.  Optionally, /sbin/mdadm can us the file /etc/mdadm.conf in a way
that is similar to how /etc/raidtab was used.  Please be aware that the format
is different.

Sections 5.9.8.2 and 5.9.9.2 of rhel-isa still describe mkraid, raidhotadd, and
/etc/raidtab.

Thank you.
Comment 2 Michael Hideo 2007-06-06 00:41:17 EDT
Adding 'cc ecs-dev-list@redhat.com for tracking
Comment 3 Michael Hideo 2007-10-22 22:42:57 EDT
Removing automation notification
Comment 4 Douglas Silas 2010-09-01 16:37:04 EDT
This bug is inapplicable to the Deployment Guide (no raidtools references at all); closing.
Comment 5 Stephen P. Schaefer 2010-09-01 17:12:15 EDT
Is documentation not included within Red Hat support for Red Hat Enterprise Linux 4?  That is the edition against which this bug was originally filed, and the documentation for that edition continues to describe raidtools, whereas Red Hat Enterprise Linux 4 uses mdadm.  I haven't actually tried, but I suspect the Red Hat Enterprise Linux 5 documentation of this procedure doesn't correctly describe how to work with Red Hat Enterprise Edition 4.  Please make the Red Hat Entperprise Linux 4 documentation describe Red Hat Enterprise Linux 4.

(I'm subscribed to this bug under our subscription account rfmicrodevices, but our password changed a couple weeks ago and I don't have access to it at the moment).
Comment 6 Michael Hideo 2010-09-06 17:56:31 EDT
Red Hat is unable to address this issue for documentation relating to Introduction to System Administration in Red Hat Enterprise Linux 4. Red Hat Enterprise Linux 5 is our primary area of focus for such updates and if applicable, we will consider this change for inclusion in that release.
Comment 7 Michael Hideo 2010-09-06 17:57:33 EDT
Don, can you find out if we inherited this defect somewhere in RHEL5? - Mike
Comment 8 Don Domingo 2010-09-06 21:46:01 EDT
checked both RHEL5 Deployment Guide and RHEL4 Intro to System Admin. both books describe the use of *mdadm* to create and manage RAID.

i checked the source for each one, but the latest copies of each are available here:
http://docs.redhat.com/docs/en-US/index.html

the ISA still mentioned the raidtools man page once, but that's about it. i've removed it from source just now, but since this bug is about confirming if we document RAID creation through mdadm, i'm closing this as CURRENTRELEASE.
Comment 9 Richard Shedron 2010-09-07 13:18:35 EDT
I looked at RHEL4 ISA and RHEL5 Deployment Guide in http://docs.redhat.com/docs/en-US/index.html

While I no longer see a description of how to use raidtools in RHEL4 ISA, I am also unable to find a description of mdadm in either doc.  I do see a description of how to use Disk Druid during a graphical installation.  Maybe that is sufficient for your purposes since the docs don't describe the wrong tools any more.  It just seemed like the original intent was to help people use raid related utilities after installation.
Comment 10 Don Domingo 2010-09-08 19:13:34 EDT
Hi Richard,

the RHEL4 ISA documents how to create and configure RAID with mdadm:
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/4/html/Introduction_To_System_Administration/s3-storage-raid-credel-after.html

the RHEL5 Deployment Guide only documents the creation and configuration of RAID with Disk Druid. it's possible that we left out mdadm since it already ships with a pretty extensive man page. i'll clone this bug as a Feature Request and see if the Deployment Guide writer/s will add mdadm documentation in RHEL5.6.
Comment 11 Richard Shedron 2010-09-09 13:27:23 EDT
I see it now.  Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.