Bug 1563535 - L2TP VPN unable to connect after upgrading Kernel from 4.14.14-300 to 4.15.x-xxx
Summary: L2TP VPN unable to connect after upgrading Kernel from 4.14.14-300 to 4.15.x-xxx
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 06:42 UTC by Armin
Modified: 2018-09-27 03:28 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 18:04:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Armin 2018-04-04 06:42:01 UTC
Description of problem:


Version-Release number of selected component (if applicable):
4.15.x-xxx

How reproducible:
Upgrading Kernel from 4.14 to 4.15

Steps to Reproduce:
1.
2.
3.

Actual results:
Breaking L2TP/IPSec VPN. Clients are not able to connect to VPN server via L2TP/IPSec VPN.

Expected results:

Additional info:
Upgrading Kernel form 4.14.14-300 to any version of Kernel 4.15 causes issue. I tried different versions of Kernel 4.15 and all of them have same problem. The last Kernel I tried is 4.15.14-300, but still the issue is exist with no resolution.

The message log file says:

Apr  3 20:34:19 VPN xl2tpd[1839]: xl2tpd[1839]: udp_xmit failed to 24.80.146.236:1701 with err=-1:No such device
Apr  3 20:34:21 VPN xl2tpd[1839]: xl2tpd[1839]: udp_xmit failed to 24.80.146.236:1701 with err=-1:No such device
Apr  3 20:34:21 VPN xl2tpd[1839]: xl2tpd[1839]: udp_xmit failed to 24.80.146.236:1701 with err=-1:No such device
Apr  3 20:34:25 VPN xl2tpd[1839]: xl2tpd[1839]: udp_xmit failed to 24.80.146.236:1701 with err=-1:No such device
Apr  3 20:34:25 VPN xl2tpd[1839]: xl2tpd[1839]: udp_xmit failed to 24.80.146.236:1701 with err=-1:No such device

Comment 1 Armin 2018-04-05 07:33:25 UTC
I could not set Priority and Severity for this bug, but I would like to set both to "High".

Comment 2 Laura Abbott 2018-04-05 14:24:43 UTC
Can you try the 4.16.0 kernel https://koji.fedoraproject.org/koji/buildinfo?buildID=1064627 I swear I saw a regression/fix related to L2TP but I can't find it in my e-mail

Comment 3 Armin 2018-04-05 17:21:27 UTC
I could resolve the L2TP connection issues by installing xl2tpd-1.3.8-7.fc27.x86_64 from testing repository update with kernel 4.15.14-300.

Comment 4 Laura Abbott 2018-04-05 18:04:36 UTC
Thanks for letting us know. Feel free to reopen if the bug shows up again.


Note You need to log in before you can comment on or make changes to this bug.