Bug 156357 - Broken symbolic links after mount of a samba share
Broken symbolic links after mount of a samba share
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Still unresolved
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-29 07:22 EDT by hipodilski
Modified: 2015-01-04 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 08:48:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hipodilski 2005-04-29 07:22:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
I'm running fedora core 3 with all the updates from redhat and freshrpms.net.
I'm having a situation where i have a samba server that gives it's NETBIOS resources to a local network of ten machines. On the samba server there are symbolic links that point to a different places on the samba server's filesystem, using windows 98/XP and so far fedora core 1 I see this samba share normally during browse and disk map/mount. When i switched to fedora core 3 and i mount the filesystem with those share. The symbolic links that are on the samba server are been detected as links on my local filesystem, and all that links are broken because the resources where they point to are phisically located on the samba server. And the local server should not even know that there are symbolic links on the server. The issue is not with the samba server where i use the share from since the same server works perfect with fedora core3 and links are not seen as links on my local filesystem.
I tried to use mount.cifs mount.smbfs and mount -t smbfs/cifs for the mount of the location and using all of them caused the same problem. I've tried to pass the -o nodev option to the mount binaries so no special files are found as special files as it is written in the mount manual and that didn't worked out again. I've tried to use a compiled mount.smbfs binary from another linux box that mounts the share normally with on the fedora core 3 machine and using it the result was the same no luck. The only thing that lefts in my mind is that there is some problem with the fedora kernel or something.
Here is an example of what i've did.
[root@davidian /]# uname -a;
Linux davidian 2.6.11-1.14_FC3 #1 Thu Apr 7 19:23:49 EDT 2005 i686 athlon i386 GNU/Linux
[root@davidian /]#
[root@davidian /]# cat /etc/fedora-release
Fedora Core release 3 (Heidelberg)
[root@davidian /]#
[root@davidian /]# /sbin/mount.cifs //ARMAGEDDON/hipo /mnt/temp/ -o user=hipo%mypass
[root@davidian /]# ls -al /mnt/temp/clients/design.bg/
total 12
drwxr-xr-x  2 root root   0 Mar  1 10:20 .
drwxr-xr-x  5 5031 users  0 Apr 14 16:44 ..
lrwxrwxrwx  1 root root  59 Oct  5  2004 Content_management -> /var/lib/apache/htdocs/clients/design.bg/Content_management
lrwxrwxrwx  1 root root  63 Oct  5  2004 Ring-Tones_Maintenance -> /var/lib/apache/htdocs/clients/design.bg/Ring-Tones_Maintenance
lrwxr-xr-x  1 root root  45 Mar  1 10:20 Test -> /var/lib/apache/htdocs/clients/design.bg/Test
[root@davidian /]#
As you can see the links are detected as to be local instead of just following them on the server. The samba server is currently running on slackware.
[hipo@hipo:]$  /usr/local/samba/sbin/smbd -V
Version 3.0.13
[hipo@hipo:]$

I hope the problem will be fixed soon.

regards,
hip0
-=-=

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get linux box running samba and create few symlinks in the samba dir tree there
2. mount the share under fedora core 3
3. The symbolic link from the samba server is being detected as a symbolic link to the local filesystem and ofcourse it's broken since it doesn't exists.
  

Actual Results:  Broken symbolic links after samba mount

Additional info:
Comment 1 Tim Waugh 2005-04-29 08:32:34 EDT
Nothing to do with the 'symlinks' package, anyway. :-)

Reassigning to the correct component.
Comment 3 Jay Fenlason 2005-05-01 09:39:29 EDT
Is the Samba server configured with "unix extensions = no"?  If not, this is
expected behavior.
Comment 4 hipodilski 2005-05-03 02:35:53 EDT
Here is the section of my samba conf
[%U]
   comment = %U's shares
   path = /samba/%U
   browseable = yes
   read only = no
   writable = yes
   printable = no
   force user = httpd
   force group = httpd
   force create mode = 0755
   force directory mode = 0755
   follow symlinks = yes
   guest ok = no
   #unix extensions = no
I've tried to add unix extensions = no. And restarted the samba server with no luck.
Comment 5 hipodilski 2005-05-09 11:45:14 EDT
Bug still needs to be resolved! It still exists!
Comment 6 hipodilski 2005-05-13 08:48:21 EDT
Hi there. That was not a bug. I tried to day to put unix extensions = no to my
[global] section in the conf on my samba server and that fixed the problem. Many
thanks for your help !!!

Note You need to log in before you can comment on or make changes to this bug.