Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563630 - Unwanted docker-runc warnings in /var/log/messages
Summary: Unwanted docker-runc warnings in /var/log/messages
Keywords:
Status: CLOSED DUPLICATE of bug 1485832
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 11:17 UTC by Suhaas Bhat
Modified: 2021-06-10 15:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 21:03:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Suhaas Bhat 2018-04-04 11:17:44 UTC
Description of problem:
We can see unwanted docker-runc warnings in /var/log/messages with the latest docker package

Version-Release number of selected component (if applicable):
docker-1.13.1-53.git774336d.el7.x86_64

How reproducible:
Able to reproduce this with both Overlay2 and device-mapper storage drivers.

[root@xxx Downloads]# cat /var/log/messages | grep -i "failed to ret"
Mar 22 10:38:21 dhcp193-13 dockerd-current: time="2018-03-22T10:38:21.678205320+05:30" level=warning msg="failed to retrieve docker-runc version: unknown output format: runc version 1.0.0-rc2\nspec: 1.0.0-rc2-dev\n"
Mar 22 10:38:21 dhcp193-13 dockerd-current: time="2018-03-22T10:38:21.678272920+05:30" level=warning msg="failed to retrieve docker-init version"

Expected results:
Should not contain these warnings

Additional info:
Issue : https://github.com/moby/moby/issues/28494
Fix : https://github.com/moby/moby/pull/28310

Comment 2 Derrick Ornelas 2018-04-05 21:03:56 UTC

*** This bug has been marked as a duplicate of bug 1485832 ***


Note You need to log in before you can comment on or make changes to this bug.