Bug 1563646 - Unable to disable nova-compute with unified CLI command
Summary: Unable to disable nova-compute with unified CLI command
Keywords:
Status: CLOSED DUPLICATE of bug 1495489
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: nova-maint
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 11:45 UTC by Gurenko Alex
Modified: 2019-09-09 14:37 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-06 14:15:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gurenko Alex 2018-04-04 11:45:47 UTC
Description of problem: when following scaling down compute nodes proccedure [0] following command fails: openstack compute service set compute-1 nova-compute --disable


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. openstack compute service set compute-1 nova-compute --disable

Actual results:

Failed to set service status to disabled
Compute service nova-compute of host compute-1 failed to set.

Expected results:

nova-compute disabled successfully

Additional info:
[0] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html-single/director_installation_and_usage/#sect-Removing_Compute_Nodes

nova service-disable works fine.

Same bug was present in RHOS12 and was not fixed, but I cannot find it right now.

Comment 1 Ollie Walsh 2018-04-06 14:15:07 UTC

*** This bug has been marked as a duplicate of bug 1495489 ***


Note You need to log in before you can comment on or make changes to this bug.