Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563654 - HA VM with lease paused with i/o err is restarted to an active host, but doesn't get OS.
Summary: HA VM with lease paused with i/o err is restarted to an active host, but does...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:04 UTC by Polina
Modified: 2018-06-18 11:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-18 11:35:59 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine, libvirt and vdsm logs (3.17 MB, application/x-gzip)
2018-04-04 12:04 UTC, Polina
no flags Details
guest log (14.58 KB, text/plain)
2018-04-07 13:53 UTC, Polina
no flags Details

Description Polina 2018-04-04 12:04:43 UTC
Created attachment 1417246 [details]
engine, libvirt and vdsm logs

Description of problem: HA VM with lease, that was paused with i/o error,  is restarted to the active host, but doesn't get OS


Version-Release number of selected component (if applicable):vdsm, engine, libvirt logs.


How reproducible:100%


Steps to Reproduce:
1.Run HA VM (bootable iscsi disk) with lease on iscsi_0 SD.
2.block the iscsi on the host where VM is started. Wait >80sec


Actual results: VM is started on another active host,  but no OS. No IP


Expected results: VM is started on another active host, got OS.


Additional info: logs attached: engine.log (vm name='golden_env_mixed_virtio_2_1' - see at the end of the log).  libvirt and vdsm from the host to where the VM was restarted and didn't get the IP

Comment 1 Michal Skrivanek 2018-04-04 12:50:28 UTC
we need guest logs, can you please add those? Or check using graphical console what's going on in the guest after restart.
Does it boot correctly when you run the same VM (normally, from Down) on that host?

Comment 2 Polina 2018-04-07 13:53:33 UTC
Created attachment 1418583 [details]
guest log

Comment 3 Polina 2018-04-07 14:11:24 UTC
the guest log is attached
in the console, there is booting stuck.
the same VM starts on the same host from Down randomly successfully, which could be related to another bug . but when VM is restarted as result of i/o error pause, it always has the OS problem

Comment 4 Polina 2018-04-07 14:56:52 UTC
could be related to https://bugzilla.redhat.com/show_bug.cgi?id=1562750

Comment 5 Michal Skrivanek 2018-04-16 12:54:12 UTC
since that bug 1562750 reproduces about 50% can you tell if this particular issue really happens all the time or roughly 50%?
Maybe you can try with different disk configuration? (or even just a diskless VM) and reproduce that problem independently to HA

Comment 6 Polina 2018-06-16 19:08:19 UTC
Tested on rhv-release-4.2.4-5-001.noarch, vdsm-4.20.31-1.el7ev.x86_64, ibvirt-3.9.0-14.el7_5.5.x86_64
The problem is not reproduced. VM is restarted and get IP.


Note You need to log in before you can comment on or make changes to this bug.