Bug 1563670 - unable to register to the candlepin deployed with latest code from master
Summary: unable to register to the candlepin deployed with latest code from master
Keywords:
Status: CLOSED DUPLICATE of bug 1563436
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: candlepin-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:22 UTC by Shwetha Kallesh
Modified: 2018-04-04 15:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-04 15:00:15 UTC


Attachments (Terms of Use)

Description Shwetha Kallesh 2018-04-04 12:22:46 UTC
Description of problem:
unable to register to the candlepin deployed with latest code from master

Version-Release number of selected component (if applicable):
subscription management server: 2.3.4-1

[root@shwetha-candlepin server]# git show
commit dcc7929da7286f346ca38f8f262501ee7272fbc3
Merge: c28f8fd 3179f23

How reproducible:


Steps to Reproduce:
hedInputException.from:63
[root@localhost ~]# subscription-manager register --user ***** --password **** --org admin
Registering to: shwetha-candlepin.usersys.redhat.com:8443/candlepin
Runtime Error com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
 at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"]) at com.fasterxml.jackson.databind.exc.MismatchedInputException.from:63


Actual results:


Expected results:


Additional info:
Access.log:
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
[root@shwetha-candlepin server]# tail -f /var/log/candlepin/access.log
10.76.99.7 - - [04/Apr/2018:17:19:13 +0530] "GET /candlepin/users/admin/owners HTTP/1.1" 200 1515 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.010,req=88158d00-dfa5-422d-964b-816704630f5a"
10.76.99.7 - - [04/Apr/2018:17:19:16 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.002,req=81016c0e-6e63-4a02-b7b4-de7fb449bd7c"
10.76.99.7 - - [04/Apr/2018:17:19:16 +0530] "POST /candlepin/consumers?owner=admin HTTP/1.1" 400 611 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.038,req=0ff4049c-f188-4f4e-8c4f-53d75019dfff"
10.76.99.7 - - [04/Apr/2018:17:20:19 +0530] "GET /candlepin/users/admin/owners HTTP/1.1" 200 1515 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.014,req=9ee68282-742d-4c09-b34c-2685b2a34c1a"
10.76.99.7 - - [04/Apr/2018:17:20:22 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.003,req=dac86389-ea74-44a1-ba58-43963814de84"
10.76.99.7 - - [04/Apr/2018:17:20:22 +0530] "POST /candlepin/consumers?owner=admin HTTP/1.1" 400 611 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.114,req=e50e9e70-98d5-4efc-8dbe-c7d025fd91a4"
10.76.99.7 - - [04/Apr/2018:17:21:36 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.001,req=5bd58eea-8f5c-438c-b0a6-2f6290952718"
10.76.99.7 - - [04/Apr/2018:17:21:36 +0530] "POST /candlepin/consumers?owner=admin HTTP/1.1" 400 611 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.086,req=2f868959-b90f-4b8f-ac59-a82bfa7529e2"
10.76.99.7 - - [04/Apr/2018:17:35:24 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.007,req=f7f66515-29e0-422e-838b-735aad033262"
10.76.99.7 - - [04/Apr/2018:17:35:24 +0530] "GET /candlepin/status HTTP/1.1" 200 516 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.004,req=fc90adf3-bb47-4e27-afdd-35db9c0a4276"
10.76.99.7 - - [04/Apr/2018:17:51:31 +0530] "GET /candlepin/users/admin/owners HTTP/1.1" 200 1515 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.017,req=c9c60962-7446-402a-b06d-3dd6b3dbf3aa"
10.76.99.7 - - [04/Apr/2018:17:51:34 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.002,req=c849f7aa-c968-423c-a669-83de885ec752"
10.76.99.7 - - [04/Apr/2018:17:51:34 +0530] "POST /candlepin/consumers?owner=admin HTTP/1.1" 400 611 "" "RHSM/1.0 (cmd=subscription-manager) sm/1.20.10-3.el6" "req_time=0.043,req=f1012ec6-b108-41b8-8116-cd68afdbe6af"




candlepin.log:
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
[root@shwetha-candlepin server]# tail -f /var/log/candlepin/candlepin.log 
2018-04-04 17:20:00,062 [thread=QuartzScheduler_Worker-7] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Finished deleting jobs from scheduler
2018-04-04 17:20:00,111 [thread=QuartzScheduler_Worker-8] [job=SweepBarJob-f90b7c40-3413-499e-b48a-650d00f0d5df, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.SweepBarJob
2018-04-04 17:20:00,113 [thread=QuartzScheduler_Worker-8] [job=SweepBarJob-f90b7c40-3413-499e-b48a-650d00f0d5df, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=2
2018-04-04 17:20:00,211 [thread=QuartzScheduler_Worker-10] [job=CertificateRevocationListTask-67e03700-2be8-4370-8fc0-4278da4f2bdf, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.CertificateRevocationListTask
2018-04-04 17:20:00,211 [thread=QuartzScheduler_Worker-10] [job=CertificateRevocationListTask-67e03700-2be8-4370-8fc0-4278da4f2bdf, org=, csid=] INFO  org.candlepin.pinsetter.tasks.CertificateRevocationListTask - Executing CRL Job. CRL filePath=/var/lib/candlepin/candlepin-crl.crl
2018-04-04 17:20:00,213 [thread=QuartzScheduler_Worker-10] [job=CertificateRevocationListTask-67e03700-2be8-4370-8fc0-4278da4f2bdf, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=2
2018-04-04 17:20:05,101 [thread=QuartzScheduler_Worker-12] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Deleting 0 cancelled jobs from scheduler.
2018-04-04 17:20:05,114 [thread=QuartzScheduler_Worker-12] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Finished deleting jobs from scheduler
2018-04-04 17:20:10,047 [thread=QuartzScheduler_Worker-11] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Deleting 0 cancelled jobs from scheduler.
2018-04-04 17:20:10,047 [thread=QuartzScheduler_Worker-11] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Finished deleting jobs from scheduler
2018-04-04 17:20:15,107 [thread=QuartzScheduler_Worker-1] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Deleting 0 cancelled jobs from scheduler.
2018-04-04 17:20:15,120 [thread=QuartzScheduler_Worker-1] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Finished deleting jobs from scheduler
2018-04-04 17:20:19,465 [thread=http-bio-8443-exec-9] [req=9ee68282-742d-4c09-b34c-2685b2a34c1a, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/users/admin/owners
2018-04-04 17:20:19,479 [thread=http-bio-8443-exec-9] [req=9ee68282-742d-4c09-b34c-2685b2a34c1a, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=14
2018-04-04 17:20:20,048 [thread=QuartzScheduler_Worker-3] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Deleting 0 cancelled jobs from scheduler.
2018-04-04 17:20:20,048 [thread=QuartzScheduler_Worker-3] [job=CancelJobJob-9c5b8d07-0fad-459c-b7c3-bbf5f55b27e2, org=, csid=] INFO  org.candlepin.pinsetter.core.PinsetterKernel - Finished deleting jobs from scheduler
2018-04-04 17:20:22,158 [thread=http-bio-8443-exec-6] [req=dac86389-ea74-44a1-ba58-43963814de84, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2018-04-04 17:20:22,161 [thread=http-bio-8443-exec-6] [req=dac86389-ea74-44a1-ba58-43963814de84, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=3
2018-04-04 17:20:22,353 [thread=http-bio-8443-exec-11] [req=e50e9e70-98d5-4efc-8dbe-c7d025fd91a4, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=POST, uri=/candlepin/consumers?owner=admin
2018-04-04 17:20:22,463 [thread=http-bio-8443-exec-11] [req=e50e9e70-98d5-4efc-8dbe-c7d025fd91a4, org=, csid=7abc1c4549c54eeda45c581a38df2e34] ERROR org.candlepin.common.exceptions.mappers.CandlepinExceptionMapper - Runtime Error com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
 at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"]) at com.fasterxml.jackson.databind.exc.MismatchedInputException.from:63
org.jboss.resteasy.spi.ReaderException: com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
 at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"])
	at org.jboss.resteasy.core.MessageBodyParameterInjector.inject(MessageBodyParameterInjector.java:183)
	at org.jboss.resteasy.core.MethodInjectorImpl.injectArguments(MethodInjectorImpl.java:89)
	at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:112)
	at org.jboss.resteasy.core.ResourceMethodInvoker.invokeOnTarget(ResourceMethodInvoker.java:296)
	at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:250)
	at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:237)
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:356)
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:179)
	at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:220)
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:56)
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:51)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
	at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:263)
	at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:178)
	at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:62)
	at org.candlepin.servlet.filter.EventFilter.doFilter(EventFilter.java:61)
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
	at org.candlepin.servlet.filter.ContentTypeHackFilter.doFilter(ContentTypeHackFilter.java:58)
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
	at org.candlepin.common.filter.LoggingFilter.doFilter(LoggingFilter.java:113)
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
	at org.candlepin.servlet.filter.CandlepinPersistFilter.doFilter(CandlepinPersistFilter.java:48)
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
	at org.candlepin.servlet.filter.CandlepinScopeFilter.doFilter(CandlepinScopeFilter.java:68)
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
	at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:118)
	at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:113)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:218)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:110)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:506)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:169)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:962)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:445)
	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1087)
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:637)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:748)
Caused by: com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
 at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"])
	at com.fasterxml.jackson.databind.exc.MismatchedInputException.from(MismatchedInputException.java:63)
	at com.fasterxml.jackson.databind.DeserializationContext.reportInputMismatch(DeserializationContext.java:1342)
	at com.fasterxml.jackson.databind.DeserializationContext.handleMissingInstantiator(DeserializationContext.java:1031)
	at com.fasterxml.jackson.databind.deser.ValueInstantiator._createFromStringFallbacks(ValueInstantiator.java:371)
	at com.fasterxml.jackson.databind.deser.std.StdValueInstantiator.createFromString(StdValueInstantiator.java:323)
	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.deserializeFromString(BeanDeserializerBase.java:1366)
	at com.fasterxml.jackson.databind.deser.BeanDeserializer._deserializeOther(BeanDeserializer.java:171)
	at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:161)
	at com.fasterxml.jackson.databind.deser.impl.MethodProperty.deserializeAndSet(MethodProperty.java:127)
	at com.fasterxml.jackson.databind.deser.BeanDeserializer.vanillaDeserialize(BeanDeserializer.java:288)
	at com.fasterxml.jackson.databind.deser.BeanDeserializer.deserialize(BeanDeserializer.java:151)
	at com.fasterxml.jackson.databind.ObjectReader._bind(ObjectReader.java:1574)
	at com.fasterxml.jackson.databind.ObjectReader.readValue(ObjectReader.java:965)
	at com.fasterxml.jackson.jaxrs.base.ProviderBase.readFrom(ProviderBase.java:815)
	at org.jboss.resteasy.core.interception.AbstractReaderInterceptorContext.readFrom(AbstractReaderInterceptorContext.java:59)
	at org.jboss.resteasy.core.interception.ServerReaderInterceptorContext.readFrom(ServerReaderInterceptorContext.java:62)
	at org.jboss.resteasy.core.interception.AbstractReaderInterceptorContext.proceed(AbstractReaderInterceptorContext.java:51)
	at org.jboss.resteasy.plugins.interceptors.encoding.GZIPDecodingInterceptor.aroundReadFrom(GZIPDecodingInterceptor.java:59)
	at org.jboss.resteasy.core.interception.AbstractReaderInterceptorContext.proceed(AbstractReaderInterceptorContext.java:53)
	at org.jboss.resteasy.core.MessageBodyParameterInjector.inject(MessageBodyParameterInjector.java:150)
	... 49 common frames omitted
2018-04-04 17:20:22,464 [thread=http-bio-8443-exec-11] [req=e50e9e70-98d5-4efc-8dbe-c7d025fd91a4, org=, csid=7abc1c4549c54eeda45c581a38df2e34] WARN  org.candlepin.audit.EventSinkImpl - Rolling back ActiveMQ transaction.
2018-04-04 17:20:22,467 [thread=http-bio-8443-exec-11] [req=e50e9e70-98d5-4efc-8dbe-c7d025fd91a4, org=, csid=7abc1c4549c54eeda45c581a38df2e34] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=400, content-type="application/json", time=114

   

rhsm.log:
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 2018-04-04 07:51:36,803 [DEBUG] subscription-manager:11921:MainThread @connection.py:495 - Loaded CA certificates from /etc/rhsm/ca/: candlepin-ca.pem, shwetha-candlepin.pem, redhat-uep.pem
    2018-04-04 07:51:36,805 [DEBUG] subscription-manager:11921:MainThread @connection.py:543 - Making request: POST /candlepin/consumers?owner=admin
    2018-04-04 07:51:36,990 [INFO] subscription-manager:11921:MainThread @connection.py:586 - Response: status=400, requestUuid=2f868959-b90f-4b8f-ac59-a82bfa7529e2, request="POST /candlepin/consumers?owner=admin"
    2018-04-04 07:51:36,991 [ERROR] subscription-manager:11921:MainThread @managercli.py:1116 - Runtime Error com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
     at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"]) at com.fasterxml.jackson.databind.exc.MismatchedInputException.from:63
    Traceback (most recent call last):
      File "/usr/lib64/python2.6/site-packages/subscription_manager/managercli.py", line 1113, in _do_command
        type=self.options.consumertype
      File "/usr/lib64/python2.6/site-packages/rhsmlib/services/register.py", line 80, in register
        type=type
      File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 966, in registerConsumer
        return self.conn.request_post(url, params)
      File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 693, in request_post
        return self._request("POST", method, params, headers=headers)
      File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 716, in _request
        info=info, headers=headers)
      File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 595, in _request
        self.validateResponse(result, request_type, handler)
      File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 654, in validateResponse
        raise RestlibException(response['status'], error_msg, response.get('headers'))
    RestlibException: Runtime Error com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot construct instance of `org.candlepin.dto.api.v1.ConsumerTypeDTO` (although at least one Creator exists): no String-argument constructor/factory method to deserialize from String value ('system')
     at [Source: (org.candlepin.common.filter.TeeHttpServletRequest$1); line: 1, column: 10406] (through reference chain: org.candlepin.dto.api.v1.ConsumerDTO["type"]) at com.fasterxml.jackson.databind.exc.MismatchedInputException.from:63

Comment 1 vritant 2018-04-04 15:00:15 UTC

*** This bug has been marked as a duplicate of bug 1563436 ***


Note You need to log in before you can comment on or make changes to this bug.