Bug 1563680 - Package Review: libocxl - library for OpenCAPI accelerator
Summary: Package Review: libocxl - library for OpenCAPI accelerator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: 28
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1654309 1523862 1524656
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:31 UTC by Michel Normand
Modified: 2019-03-07 15:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 20:24:06 UTC
Type: Bug
dan: fedora-review+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
IBM Linux Technology Center 166425 0 None None None 2019-06-14 14:20:14 UTC

Description Michel Normand 2018-04-04 12:31:36 UTC
spec: https://michelmno.fedorapeople.org/libocxl/libocxl.spec
srpm: https://michelmno.fedorapeople.org/libocxl/SRPMS/libocxl-1.0-1.fc29.src.rpm

Summary: Allows to implement a user-space driver for an OpenCAPI accelerator

I built locally for rawhide and kept generated rpms in 
https://michelmno.fedorapeople.org/libocxl/RPMS/

Comment 1 Michel Normand 2018-04-04 12:33:15 UTC
Hello Dan, could you take this bug for review ?

Comment 2 Dan Horák 2018-04-04 12:44:49 UTC
yup, taking

Comment 3 Robert-André Mauchin 🐧 2018-04-04 15:46:39 UTC
 - Please add a comment for each patch explaining what they do

 - Use the new %ldconfig_scriptlets macro instead of:

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

   See https://fedoraproject.org/wiki/Changes/Removing_ldconfig_scriptlets#Upgrade.2Fcompatibility_impact

 - Build error:

BUILDSTDERR: /var/tmp/rpm-tmp.PWgKId: line 41: cd: libocxl-1.0: No such file or directory

   Fix it by passing the correct directory to %setup:

%setup -q -n %{name}-%{version}-RELEASE

 - You could replace:

%setup -q -n %{name}-%{version}-RELEASE
%patch1 -p1
%patch2 -p1
%patch3 -p1

   with: 

%autosetup -p1 -n %{name}-%{version}-RELEASE

 - Patch error:

+ /usr/bin/cat /builddir/build/SOURCES/irq_trace_ppc64.patch
+ /usr/bin/patch -p1 -s --fuzz=0 --no-backup-if-mismatch
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n] 
1 out of 1 hunk ignored -- saving rejects to file src/irq.c.rej

Patch irq_trace_ppc64.patch is already applied in the 1.0 Release.

 - Own /usr/share/libocxl by removing the * in %files:

%{_datarootdir}/libocxl

[!]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/libocxl

Actually since it seems to be documentation, I believe it should be installed in %{_pkgdocdir} (i.e /usr/share/doc/libocxl ). Since you're already patching the Makefile, you could probably change the install directory of the docs.


 - The docs should be split in a separate noarch -docs subpackage:

[!]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
     Note: Arch-ed rpms have a total of 1228800 bytes in /usr/share

 - The Makefile doesn't keep timestamps while installing files. To fix this, replace the occurrences of "install" with $(INSTALL), i.e.:

	$(INSTALL) -m 0755 obj/$(LIBNAME) $(libdir)/
	cp -d obj/libocxl.so obj/$(LIBSONAME) $(libdir)/
	$(INSTALL) -m 0644 src/include/libocxl.h  $(includedir)/
	$(INSTALL) -m 0644 -D docs/man/man3/* $(mandir)/man3
	$(INSTALL) -m 0644 -D docs/html/*.* $(datadir)/libocxl
	$(INSTALL) -m 0644 -D docs/html/search/* $(datadir)/libocxl/search

The $(INSTALL) variable is set up by the %make_install macro, replacing it with install -p, which keeps timestamps.



Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "Unknown or generated", "*No copyright* Apache
     (v2.0)". 22 files have unknown license. Detailed output of
     licensecheck in /home/bob/packaging/review/libocxl/review-
     libocxl/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/share/libocxl
[!]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/libocxl
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[!]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[!]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Fully versioned dependency in subpackages if applicable.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[!]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
     Note: Arch-ed rpms have a total of 1228800 bytes in /usr/share
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: libocxl-1.0-1.fc29.x86_64.rpm
          libocxl-devel-1.0-1.fc29.x86_64.rpm
          libocxl-debuginfo-1.0-1.fc29.x86_64.rpm
          libocxl-debugsource-1.0-1.fc29.x86_64.rpm
          libocxl-1.0-1.fc29.src.rpm
libocxl-devel.x86_64: W: only-non-binary-in-usr-lib
libocxl-debugsource.x86_64: W: no-documentation
5 packages and 0 specfiles checked; 0 errors, 0 warnings.

Comment 4 Michel Normand 2018-04-05 09:42:13 UTC
(In reply to Robert-André Mauchin from comment #3)
> [CUT] ...
> Actually since it seems to be documentation, I believe it should be
> installed in %{_pkgdocdir} (i.e /usr/share/doc/libocxl ). Since you're
> already patching the Makefile, you could probably change the install
> directory of the docs.
> 
> 
>  - The docs should be split in a separate noarch -docs subpackage:
> 
> [!]: Large data in /usr/share should live in a noarch subpackage if package
>      is arched.
>      Note: Arch-ed rpms have a total of 1228800 bytes in /usr/share
> 

Thank your for all comments;
Question: how to define in spec the *-docs subpackage as noarch package ? while other packages are arch specific (with ExclusiveArch)

Comment 5 Michel Normand 2018-04-05 09:51:25 UTC
(In reply to Michel Normand from comment #4)
> 
> Thank your for all comments;
> Question: how to define in spec the *-docs subpackage as noarch package ?
> while other packages are arch specific (with ExclusiveArch)

answering myself: using BuildArch in related Package definition.

Comment 6 Dan Horák 2018-04-05 09:53:04 UTC
Just add "BuildArch: noarch" into the "%package docs" section.

I agree with Robert-Andre's review, but you should be able to drop the "ldconfig" stuff completely as standard stuff is handled automagically.

Comment 7 Michel Normand 2018-04-05 10:15:09 UTC
spec and srpm updated from Robert-Andre's review
spec: https://michelmno.fedorapeople.org/libocxl/libocxl.spec
srpm: https://michelmno.fedorapeople.org/libocxl/SRPMS/libocxl-1.0.0-1.fc29.src.rpm

Dan, I already added the suggested %ldconfig_scriptlets, should I remove it ?

Comment 8 Dan Horák 2018-04-05 11:14:27 UTC
If we won't plan to include libocxl to F-27 (and I think it's not necessary, F-28+ should be good), then you can remove the ldconfig scriptlets.

Comment 9 Michel Normand 2018-04-05 11:47:03 UTC
done

Comment 10 Dan Horák 2018-04-05 12:15:49 UTC
- the Release tag value should be 0.1 as the 1.0.0 version is in beta (see https://fedoraproject.org/wiki/Packaging:Versioning#Prerelease_versions)
- I would put the man pages to -devel, but kept the html in the separate -docs, this is the usual split, but aren't the HTML docs duplicate of the man pages content-wise (just different format)?
- you can use %{name}-%{version} in the Source0 URL
- I would split the BuildRequires into 2 lines, for more complex packages it's then easier to track changes in BR

Comment 11 Michel Normand 2018-04-05 14:12:01 UTC
I updated the spec file for your previous comments
except the man pages and html ones both generated by doxygen, 
so kept them  both in the noarch package.

Comment 12 Michel Normand 2018-04-10 07:48:11 UTC
(In reply to Michel Normand from comment #11)
> I updated the spec file for your previous comments
> except the man pages and html ones both generated by doxygen, 
> so kept them  both in the noarch package.

Dan is it OK or should I really split man and html in differerent rpms ?

spec and srpm updated from new beta2 upstream release (no more patches in spec)
spec: https://michelmno.fedorapeople.org/libocxl/libocxl.spec
srpm: https://michelmno.fedorapeople.org/libocxl/SRPMS/libocxl-1.0.0-0.1.fc29.src.rpm

Comment 13 Dan Horák 2018-04-10 08:36:10 UTC
If the content of the man pages and html file is the same, then I would merge the man pages into the devel subpackage (where usually basic API documentation goes, I mean headers + man pages should be installed together) and removed the docs subpackage. On the other hand the html version viewed in a browser is nice, so it would make sense to keep it ...

You can use
Source0: https://github.com/OpenCAPI/%{name}/archive/%{version}-beta2/%{name}-%{version}-beta2.tar.gz
to have better named source archive file.

Comment 14 Michel Normand 2018-04-10 09:20:19 UTC
OK I moved man in *devel rpm and kept html in *docs rpm

I did not change the Source0 to ease compare with previous URL line and allow direct access from either vi or emacs editors when in spec.
URL:     https://github.com/OpenCAPI/libocxl
Source0: https://github.com/OpenCAPI/libocxl/archive/%{version}-beta2.tar.gz

Comment 15 Dan Horák 2018-04-10 11:40:02 UTC
OK, the package looks good, APPROVED.

one nitpick - the Summary for docs should be "HTML doc files for ..." (s/doxygen/HTML/) or even only "Documentation files for %{name}". Please fix before building.

Comment 16 Michel Normand 2018-04-10 15:21:30 UTC
scratch build on koji:
https://koji.fedoraproject.org/koji/taskinfo?taskID=26291946

Comment 17 Gwyn Ciesla 2018-04-10 16:38:06 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/libocxl

Comment 18 Fedora Update System 2018-04-11 07:56:54 UTC
libocxl-1.0.0-0.1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-80a761dd88

Comment 19 Fedora Update System 2018-04-11 22:58:31 UTC
libocxl-1.0.0-0.1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-80a761dd88

Comment 20 Fedora Update System 2018-04-12 20:24:06 UTC
libocxl-1.0.0-0.1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.