Bug 1563694 - [RFE] Break the main openshift playbook into phases
Summary: [RFE] Break the main openshift playbook into phases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.9.z
Assignee: Russell Teague
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 13:18 UTC by mmariyan
Modified: 2018-08-13 13:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 13:09:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description mmariyan 2018-04-04 13:18:27 UTC
1.  Proposed title of this feature request
     
Allow openshift install to be run as multi playbook steps which can be run in specific order, but independently of each other.

   2. What is the nature and description of the request?
This request should allow quicker iteration if a customer runs into install issues during openshift advanced installations or upgrades.
      
   3. Why do you need this? (List the business requirements here)
Current advanced openshift installation is time consuming (usually > 1 hour), and if an issue is encountered, advice is to uninstall and repeat install.  This may be repeated multiple times (due to typo, or unexpected issue).  The point of the ansible install is to make it easy for the customer to install openshift, but many times the install does not work the 1st time around, and one can easily loose 8 hours in a day re-trying the installation.

     
   4. How would you like to achieve this? (List the functional requirements here)
It would be a nice option, if the playbooks are run in specific 'phases'.  In order for phase2 to proceed, phase1 need to complete.  If phase2 needs variables from phase1, they would be stored in a way that phase2 does not require phase1 to be re-run.  If the playbook has 6 phases, if phase 1-4 complete, but phase5 fails...one could re-run phase5 vs. having to uninstall everything and restart.  IF the issue is a mistyped variable that was used in one of the later phases, one could 'override' the variable at run time as an extra variable, or by updating/fixing the inventory file used.      

   5. For each functional requirement listed in question 4, specify how Red Hat
     and the customer can test to confirm the requirement is successfully implemented.

The test would be to intentionally break something in each phase after phase 1, so that the playbook fails.  Fix the issue which caused the playbook to fail, and re-run that phase.  IT should finish that phase successfully.

It should not be a requirement to automatically go to the next phase if one needs to restart a phase, but it should be clear which playbooks should be run in order to complete the installation (remaining phases).

Comment 3 Russell Teague 2018-07-23 13:40:20 UTC
The ability to run individual phases of the install was added in 3.9 [1].  If a failure occurs while running the main deploy_cluster.yml playbook, the installer will indicate which phase failed and prompt the user which playbook needs to be run to try that phase again.  Each subsequent playbook will need to be run manually as there is no automatic running of the remaining playbooks.

Please note that in 3.10 the process of installation and playbook orders have changed significantly.

Please let me know if this meets the needs of this request.


[1] https://docs.openshift.com/container-platform/3.9/install_config/install/advanced_install.html#running-the-advanced-installation-individual-components

Comment 4 Scott Dodson 2018-08-13 13:09:56 UTC
This was addressed in the 3.9 release. Please open a new RFE if further enhancements are desired.


Note You need to log in before you can comment on or make changes to this bug.