Bug 1563719 - [regression] health/upgrade check failed if services stopped
Summary: [regression] health/upgrade check failed if services stopped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Uncategorized
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Nikhil Kathole
URL:
Whiteboard:
: 1563722 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 14:36 UTC by Mike McCune
Modified: 2019-09-26 15:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 14:38:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 22945 0 High Closed [regression] health/upgrade check failed if services stopped 2021-02-11 21:42:27 UTC
Red Hat Product Errata RHBA-2018:1138 0 None None None 2018-04-17 14:38:52 UTC

Description Mike McCune 2018-04-04 14:36:32 UTC
<pre>
# ./bin/foreman-maintain health check
/usr/share/ruby/csv.rb:1854:in `block (2 levels) in shift': Illegal quoting in line 2. (CSV::MalformedCSVError)
        from /usr/share/ruby/csv.rb:1816:in `each'
        from /usr/share/ruby/csv.rb:1816:in `block in shift'
        from /usr/share/ruby/csv.rb:1776:in `loop'
        from /usr/share/ruby/csv.rb:1776:in `shift'
        from /usr/share/ruby/csv.rb:1718:in `each'
        from /usr/share/ruby/csv.rb:1732:in `to_a'
        from /usr/share/ruby/csv.rb:1732:in `read'
        from /usr/share/ruby/csv.rb:1291:in `parse'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/system_helpers.rb:119:in `parse_csv'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/base_database.rb:9:in `query'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/base_database.rb:52:in `table_exist?'
        from /root/foreman_maintain/definitions/procedures/candlepin/delete_orphaned_records_from_env_content.rb:11:in `block (2 levels) in <class:DeleteOrphanedRecordsFromEnvContent>'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:224:in `instance_exec'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:224:in `block in evaluate_confines'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `each'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `all?'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `evaluate_confines'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:200:in `present?'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:53:in `block in find_present_classes'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `each'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `reduce'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `find_present_classes'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:46:in `available_procedures'
        from /root/foreman_maintain/lib/foreman_maintain.rb:96:in `allowed_available_procedures'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:7:in `<class:RunCommand>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:6:in `<module:Procedure>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:5:in `<module:Cli>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:4:in `<module:ForemanMaintain>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:3:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure_command.rb:1:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced_command.rb:1:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli.rb:7:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from ./bin/foreman-maintain:11:in `<main>'
</pre>

Steps:
1. Katello-service stop
2. foreman-maintain health check

Expected output: Check should perform.

Additional info:
Reproducible on satellite 6.2 only.
Looks like regression from https://github.com/theforeman/foreman_maintain/pull/155

Comment 1 Mike McCune 2018-04-04 14:36:37 UTC
Created from redmine issue http://projects.theforeman.org/issues/22945

Comment 3 sthirugn@redhat.com 2018-04-04 14:52:05 UTC
*** Bug 1563722 has been marked as a duplicate of this bug. ***

Comment 4 Nikhil Kathole 2018-04-04 15:26:33 UTC
VERIFIED

# rpm -qa | grep maintain
rubygem-foreman_maintain-0.1.5-1.el7sat.noarch

foreman-maintain health/upgrade check works after stopping services.

# foreman-maintain health check
Running ForemanMaintain::Scenario::FilteredScenario
================================================================================
Check for verifying syntax for ISP DHCP configurations:
No valid HTTP response (Connection failed) 0. Response: ""
              [FAIL]
Please check and verify DHCP configurations.
--------------------------------------------------------------------------------
Check for paused tasks:                                               [FAIL]
Please check whether database service is up & running state.
--------------------------------------------------------------------------------
Check whether all services are running using hammer ping:             [FAIL]
Error: Failed to open TCP connection to qe-sat6-client-arch.usersys.redhat.com:443 (Connection refused - connect(2) for "qe-sat6-client-arch.usersys.redhat.com" port 443)
--------------------------------------------------------------------------------
Continue with step [katello-service restart]?, [y(yes), n(no), q(quit)]

Comment 7 errata-xmlrpc 2018-04-17 14:38:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1138


Note You need to log in before you can comment on or make changes to this bug.