Bug 1563722 - [Regression] health/upgrade check failed if services stopped
Summary: [Regression] health/upgrade check failed if services stopped
Keywords:
Status: CLOSED DUPLICATE of bug 1563719
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 14:41 UTC by sthirugn@redhat.com
Modified: 2019-04-12 15:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-04 14:52:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 22945 0 High Closed [regression] health/upgrade check failed if services stopped 2021-02-11 21:42:16 UTC

Description sthirugn@redhat.com 2018-04-04 14:41:52 UTC
Description of problem:
[Regression] health/upgrade check failed if services stopped

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.1.4-1.el7sat.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Katello-service stop
2. foreman-maintain health check

Actual results:
# ./bin/foreman-maintain health check
/usr/share/ruby/csv.rb:1854:in `block (2 levels) in shift': Illegal quoting in line 2. (CSV::MalformedCSVError)
        from /usr/share/ruby/csv.rb:1816:in `each'
        from /usr/share/ruby/csv.rb:1816:in `block in shift'
        from /usr/share/ruby/csv.rb:1776:in `loop'
        from /usr/share/ruby/csv.rb:1776:in `shift'
        from /usr/share/ruby/csv.rb:1718:in `each'
        from /usr/share/ruby/csv.rb:1732:in `to_a'
        from /usr/share/ruby/csv.rb:1732:in `read'
        from /usr/share/ruby/csv.rb:1291:in `parse'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/system_helpers.rb:119:in `parse_csv'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/base_database.rb:9:in `query'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/base_database.rb:52:in `table_exist?'
        from /root/foreman_maintain/definitions/procedures/candlepin/delete_orphaned_records_from_env_content.rb:11:in `block (2 levels) in <class:DeleteOrphanedRecordsFromEnvContent>'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:224:in `instance_exec'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:224:in `block in evaluate_confines'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `each'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `all?'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:223:in `evaluate_confines'
        from /root/foreman_maintain/lib/foreman_maintain/concerns/metadata.rb:200:in `present?'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:53:in `block in find_present_classes'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `each'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `reduce'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:52:in `find_present_classes'
        from /root/foreman_maintain/lib/foreman_maintain/detector.rb:46:in `available_procedures'
        from /root/foreman_maintain/lib/foreman_maintain.rb:96:in `allowed_available_procedures'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:7:in `<class:RunCommand>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:6:in `<module:Procedure>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:5:in `<module:Cli>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:4:in `<module:ForemanMaintain>'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure/run_command.rb:3:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced/procedure_command.rb:1:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli/advanced_command.rb:1:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /root/foreman_maintain/lib/foreman_maintain/cli.rb:7:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from ./bin/foreman-maintain:11:in `<main>'

Expected results:
Check should perform.

Additional info:
Reproducible on satellite 6.2 only.
Looks like regression from https://github.com/theforeman/foreman_maintain/pull/155

Comment 1 sthirugn@redhat.com 2018-04-04 14:45:30 UTC
Version to be shipped: rubygem-foreman_maintain-0.1.5-1.el7sat.noarch.rpm

Comment 3 sthirugn@redhat.com 2018-04-04 14:52:05 UTC

*** This bug has been marked as a duplicate of bug 1563719 ***


Note You need to log in before you can comment on or make changes to this bug.