Bug 1563723 - OSP 13 sriov role profile settings are not implemented
Summary: OSP 13 sriov role profile settings are not implemented
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Saravanan KR
QA Contact: Maxim Babushkin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 14:43 UTC by Maxim Babushkin
Modified: 2018-04-09 03:19 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 03:19:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Maxim Babushkin 2018-04-04 14:43:13 UTC
Description of problem:
OSP 13 sriov role profile settings are not implemented

Version-Release number of selected component (if applicable):
OSP 13
Puddle 2018-03-29.1

Additional info:
Perform sriov based deployment using ComputeSriov role from the roles_data.yaml.
Sriov role profile setting does not implemented.

----------------------------------------------------
ComputeSriovParameters:
  KernelArgs: default_hugepagesz=1GB hugepagesz=1G hugepages=32 iommu=pt intel_iommu=on
  TunedProfileName: "cpu-partitioning"
  IsolCpusList: "1,2,3,4,5,16,17,18,19,20,21"

NovaReservedHostMemory: 4096
NovaVcpuPinSet: ['1,2,3,5,16,17,18,19,21']
----------------------------------------------------

The result:
Kernel argument are not applied to the grub commandline.
Tuned profile doesn't configure and activated.
Nova vcpu pin set is not set at all.

Comment 1 Saravanan KR 2018-04-04 15:06:30 UTC
Could you paste the complete deploy command used?

Comment 2 Sanjay Upadhyay 2018-04-05 10:12:24 UTC
Referring to, adding needinfo - https://bugzilla.redhat.com/show_bug.cgi?id=1563723#c1

Comment 4 Saravanan KR 2018-04-09 03:19:16 UTC
Referring to the attached templates, the deploy command does not include the environment file "host-config-and-reboot.yaml" in the overcloud_deploy.sh, which is the reason for this bug. Include this environment to see the expected behavior. I am closing this BZ, re-open it if you still see the issue after including the environment file.


---------------------------------------------------------
#!/bin/bash

openstack overcloud deploy \
--templates \
-r /home/stack/ospd-13-vlan-sriov/roles_data.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker-ha.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-sriov.yaml \
-e /home/stack/ospd-13-vlan-sriov/docker-images.yaml \
-e /home/stack/ospd-13-vlan-sriov/network-environment.yaml \
--log-file overcloud_install.log &> overcloud_install.log
-------------------------------------------------------------


Note You need to log in before you can comment on or make changes to this bug.