Bug 1563751 - Unable to install libvirt due to cyrus-sasl-lib version incompatibility
Summary: Unable to install libvirt due to cyrus-sasl-lib version incompatibility
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.5-Alt
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 15:23 UTC by Sanjay Upadhyay
Modified: 2018-04-05 13:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 13:34:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sanjay Upadhyay 2018-04-04 15:23:48 UTC
Description of problem:

yum install libvirt errors out

--> Finished Dependency Resolution
Error: Package: cyrus-sasl-gssapi-2.1.26-21.el7.x86_64 (rhel-7-server-rpms)
           Requires: cyrus-sasl-lib(x86-64) = 2.1.26-21.el7
           Installed: cyrus-sasl-lib-2.1.26-23.el7.x86_64 (@anaconda/7.5)
               cyrus-sasl-lib(x86-64) = 2.1.26-23.el7
           Available: cyrus-sasl-lib-2.1.26-17.el7.x86_64 (rhel-7-server-rpms)
               cyrus-sasl-lib(x86-64) = 2.1.26-17.el7
           Available: cyrus-sasl-lib-2.1.26-19.2.el7.x86_64 (rhel-7-server-rpms)
               cyrus-sasl-lib(x86-64) = 2.1.26-19.2.el7
           Available: cyrus-sasl-lib-2.1.26-20.el7_2.x86_64 (rhel-7-server-rpms)
               cyrus-sasl-lib(x86-64) = 2.1.26-20.el7_2
           Available: cyrus-sasl-lib-2.1.26-21.el7.x86_64 (rhel-7-server-rpms)
               cyrus-sasl-lib(x86-64) = 2.1.26-21.el7


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. image host with 7.5-beta 
2. register rhel to Red Hat OpenStack pool
3. disable all repos and enable the following --enable=rhel-7-server-rpms --enable=rhel-7-server-extras-rpms --enable=rhel-7-server-rh-common-rpms --enable=rhel-ha-for-rhel-7-server-rpms --enable=rhel-7-server-openstack-12-rpms
4. do yum update -y and then yum install libvirt -y

Actual results:



Expected results:


Additional info:

Comment 2 Daniel Berrangé 2018-04-04 15:32:18 UTC
>            Installed: cyrus-sasl-lib-2.1.26-23.el7.x86_64 (@anaconda/7.5)
>                cyrus-sasl-lib(x86-64) = 2.1.26-23.el7

So this version is presumably from the RHEL-7.5  Beta installation media

>            Available: cyrus-sasl-lib-2.1.26-17.el7.x86_64 (rhel-7-server-rpms)
>                cyrus-sasl-lib(x86-64) = 2.1.26-17.el7

While this is coming from the YUM repositories, and will be 7.4 packages still.

So, IIUC, the core problem is that you've installed 7.5 and are now trying to update with 7.4 packages, getting this version mis-match.

You would need to enable the extra repositories with the 7.5 beta packages in.

Comment 3 Jaroslav Suchanek 2018-04-05 13:34:18 UTC
On top of comment 2 it does not seem to be a libvirt problem.


Note You need to log in before you can comment on or make changes to this bug.