Bug 156394 - Unable to use up2date --register, getting invalid system credentials
Summary: Unable to use up2date --register, getting invalid system credentials
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL: Unable to register system using up2date
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 17:50 UTC by Greg Spitzer
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 17:57:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Spitzer 2005-04-29 17:50:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
I deleted my system profile (from rhn.redhat.com) and am now unable to add it back using the up2date command.

Using command line up2date, I get the following errors:

The server indicated and error:

Error class code 3:
Error Class Info: This username is already
taken, or the password is incorrect.
Explanation:
     An error has occurred while processing
your request. If this problem
     persists please enter a bug report at
bugzilla.redhat.com.
     If you choose to submit the bug report,
please be sure to include


Followed by this after I use the Cancel button:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 749, in main
    if cfg['useRhn'] and not up2dateAuth.getLoginInfo():
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 161, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 114, in login
    raise f
xmlrpclib.Fault: <Fault -9: '\nError Message:\n    Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3 or later)\nas root on this client\nError Class Code: 9\nError Class Info: Invalid System Credentials.\nExplanation: \n     An error has occurred while processing your request. If this problem\n     persists please enter a bug report at bugzilla.redhat.com.\n     If you choose to submit the bug report, please be sure to include\n     details of what you were trying to do when this error occurred and\n     details on how to reproduce this problem.\n'>

I am currently logged in and all of my information is correct (i.e. login, pw, email address, etc).  I also show 2 valid system entitlements.

Version-Release number of selected component (if applicable):
up2date-4.4.5-1, up2date-4.4.5.6-2

How reproducible:
Always

Steps to Reproduce:
1.sudo up2date --register
2.
3.
  

Actual Results:  errors provided above

Additional info:

Comment 1 Greg Spitzer 2005-04-29 17:57:11 UTC
As soon as I submitted this bug I realized what the problem was.  Sorry, it was
really a stupid mistake - please disregard.  I was inputting my email address
instead of my login name.


Note You need to log in before you can comment on or make changes to this bug.