Bug 1564190 - [abrt] pan: std::__replacement_assert(): pan killed by SIGABRT
Summary: [abrt] pan: std::__replacement_assert(): pan killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pan
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Dalloz
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bc1647d315adc0991bf7dfbd182...
: 1570277 1573004 1576959 1578500 1580062 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 15:33 UTC by Dawid Zamirski
Modified: 2018-05-30 14:08 UTC (History)
9 users (show)

Fixed In Version: pan-0.145-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-30 14:08:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (141.64 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: cgroup (351 bytes, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: core_backtrace (27.53 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: cpuinfo (1.17 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: dso_list (9.18 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: environ (4.01 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: maps (50.04 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: mountinfo (4.02 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: open_fds (742 bytes, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details
File: var_log_messages (181 bytes, text/plain)
2018-04-05 15:34 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2018-04-05 15:33:55 UTC
Description of problem:
Attemped to launch the Pan Newsreader application.

Version-Release number of selected component:
1:pan-0.144-2.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        pan
crash_function: std::__replacement_assert
executable:     /usr/bin/pan
journald_cursor: s=bff52d0526fd4c039faba6a36e66ff91;i=1038b;b=eb46d6309f1b41559290dd8e9652216c;m=5c4ba77bf;t=5691b9ba115df;x=7bac34ea656fd203
kernel:         4.16.0-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Dawid Zamirski 2018-04-05 15:34:00 UTC
Created attachment 1417823 [details]
File: backtrace

Comment 2 Dawid Zamirski 2018-04-05 15:34:01 UTC
Created attachment 1417824 [details]
File: cgroup

Comment 3 Dawid Zamirski 2018-04-05 15:34:03 UTC
Created attachment 1417825 [details]
File: core_backtrace

Comment 4 Dawid Zamirski 2018-04-05 15:34:04 UTC
Created attachment 1417826 [details]
File: cpuinfo

Comment 5 Dawid Zamirski 2018-04-05 15:34:05 UTC
Created attachment 1417827 [details]
File: dso_list

Comment 6 Dawid Zamirski 2018-04-05 15:34:06 UTC
Created attachment 1417828 [details]
File: environ

Comment 7 Dawid Zamirski 2018-04-05 15:34:07 UTC
Created attachment 1417829 [details]
File: limits

Comment 8 Dawid Zamirski 2018-04-05 15:34:08 UTC
Created attachment 1417830 [details]
File: maps

Comment 9 Dawid Zamirski 2018-04-05 15:34:09 UTC
Created attachment 1417831 [details]
File: mountinfo

Comment 10 Dawid Zamirski 2018-04-05 15:34:10 UTC
Created attachment 1417832 [details]
File: open_fds

Comment 11 Dawid Zamirski 2018-04-05 15:34:11 UTC
Created attachment 1417833 [details]
File: proc_pid_status

Comment 12 Dawid Zamirski 2018-04-05 15:34:12 UTC
Created attachment 1417834 [details]
File: var_log_messages

Comment 13 Emmanuel Pacaud 2018-04-21 13:27:14 UTC
*** Bug 1570277 has been marked as a duplicate of this bug. ***

Comment 14 Emmanuel Pacaud 2018-04-24 08:10:56 UTC
Similar problem has been detected:

This is how to replicate:

 -launch pan
 - click on 'Sent' or 'Drafts' folder

-> pan crashes

reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        pan
crash_function: std::__replacement_assert
executable:     /usr/bin/pan
journald_cursor: s=70003848dcd14bc489043320233e574c;i=c9b7;b=8de40086ee2c4c40b44bd7e3f1916ca2;m=10394422e2;t=56a4c3d7142ac;x=7f5b62f868dc98c6
kernel:         4.16.2-300.fc28.x86_64
package:        1:pan-0.144-2.fc28
reason:         pan killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            14316

Comment 15 Warren Sturm 2018-04-29 16:25:14 UTC
*** Bug 1573004 has been marked as a duplicate of this bug. ***

Comment 16 Alister 2018-05-10 20:29:15 UTC
*** Bug 1576959 has been marked as a duplicate of this bug. ***

Comment 17 alain.cf 2018-05-15 17:36:24 UTC
*** Bug 1578500 has been marked as a duplicate of this bug. ***

Comment 18 Adam Hunt 2018-05-18 06:18:18 UTC
Similar problem has been detected:

❯ pan
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name news.pan.NZB was not provided by any .service files
/usr/include/c++/8/bits/stl_vector.h:1021: std::vector<_Tp, _Alloc>::const_reference std::vector<_Tp, _Alloc>::front() const [with _Tp = const pan::Article*; _Alloc = std::allocator<const pan::Article*>; std::vector<_Tp, _Alloc>::const_reference = const pan::Article* const&]: Assertion '__builtin_expect(!this->empty(), true)' failed.
[1]    18669 abort (core dumped)  pan

~
❯

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/bin/pan
crash_function: std::__replacement_assert
executable:     /usr/bin/pan
journald_cursor: s=a19b045926d946149d42dddcbbeced93;i=2fd69;b=57e5cbcbaf834fb3980a181bac4137fe;m=18f8d4a1a2;t=56c74cbcd7eb1;x=65703712a2e26dde
kernel:         4.16.8-300.fc28.x86_64
package:        1:pan-0.144-2.fc28
reason:         pan killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 19 kawedel 2018-05-19 18:23:18 UTC
*** Bug 1580062 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2018-05-20 21:53:41 UTC
pan-0.145-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-15aa4361f6

Comment 21 Warren Sturm 2018-05-20 23:32:51 UTC
(In reply to Fedora Update System from comment #20)
> pan-0.145-1.fc28 has been submitted as an update to Fedora 28.
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-15aa4361f6

This gets over the crashes at startup and can now select groups and get a grouplist.

Comment 22 Fedora Update System 2018-05-21 17:15:05 UTC
pan-0.145-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-15aa4361f6

Comment 23 Fedora Update System 2018-05-30 14:08:31 UTC
pan-0.145-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.