Bug 1564329 - RPM1008: Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded.
Summary: RPM1008: Checksum type "sha256" is not available for all units in the reposit...
Keywords:
Status: CLOSED DUPLICATE of bug 1570862
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 00:37 UTC by matt jia
Modified: 2019-08-20 14:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 19:29:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3367901 0 None None None 2018-04-06 16:13:13 UTC

Description matt jia 2018-04-06 00:37:44 UTC
Description of problem:

Seeing this error when syncing the repo Red Hat Software Collections Source RPMs for Red Hat Enterprise Linux 7 RHEL 7 Server EUS x86_64 7.3 from upgrading 6.2 to 6.3.

This stops publishing a content view that includes this repo.

During the upgrade, the package python-pulp-rpm-common has been upgraded which has introduced a lot of new functionality. Possibly, there is a regression introduced in https://pulp.plan.io/issues/1618 which isn't accounted for this edge case in migration.
 
Version-Release number of selected component (if applicable):

6.3

How reproducible:

Normal

Steps to Reproduce:
1. upgrade 6.2 to 6.3
2. publish a content view with the above repo

Actual results:

Can't publish the content view with

RPM1008: Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded.

Expected results:

Can publish the content view.

Additional info:

In a fresh 6.3, syncing the repo doesn't have any issue.

Comment 1 Brad Buckingham 2018-04-10 15:59:33 UTC
Hi Matt,

Do you have an internal reproducer?

Comment 2 matt jia 2018-04-17 01:53:43 UTC
(In reply to Brad Buckingham from comment #1)
> Hi Matt,
> 
> Do you have an internal reproducer?

Hi Brad,

Sorry for the late reply. Unfortunately, I can't reproduce the issue. It seems like cu somehow got checksum sha256 set on this repo, whereas the upstream repo is using sha1. After cu has corrected the checksum in the db, the issue has gone.
I think we could close this bug for now.

Regards,

Matt

Comment 4 Tanya Tereshchenko 2018-04-19 12:09:57 UTC
+1 not a bug

If download policy is on_demand (no bits are on a disk) and checksum type on a distributor is set explicitly and it isn't the same as the existing checksums, a publish will fail. It's a valid failure, because it's not possible to calculate a custom checksum without rpms being downloaded.


Note You need to log in before you can comment on or make changes to this bug.