Bug 1564392 - [Sat6.3] Need an official guide how to upgrade and update disconnected Satellite
Summary: [Sat6.3] Need an official guide how to upgrade and update disconnected Satellite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Documentation
Version: 6.3.0
Hardware: All
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: Matt Werner
QA Contact: satellite-doc-list
URL:
Whiteboard:
: 1579849 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 07:18 UTC by jalviso
Modified: 2020-10-28 14:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-28 14:09:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1454570 0 high CLOSED [RFE] [6.3] Review and update the installation procedure 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 3391671 0 None None None 2018-04-11 00:04:24 UTC

Internal Links: 1454570

Description jalviso 2018-04-06 07:18:20 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html-single/upgrading_and_updating_red_hat_satellite/#upgrading_a_disconnected_satellite

Section Number and Name: 

2.3.2. Upgrading a Disconnected Satellite Server

Describe the issue: 

We need to improve this step:

8. Obtain the latest ISO file, mount it, and install the packages following the procedures in the Downloading and Installing from a Disconnected Network section of the Red Hat Satellite Installation Guide.

Suggestions for improvement: 

The KBase link provided below contains the detailed steps and is tested to update a disconnected Satellite 6.3 using the contents synced by the Satellite; example z-stream updates ( 6.3.1 and so on). We don't provide an updated ISO image for z-stream or incremental versions but the disconnected Satellite needs to be upgraded too just like any other connected Satellites. 

https://access.redhat.com/solutions/3391671
How to update a disconnected Satellite 6.3 server? 

Additional information: 

This is a way to keep a disconnected Satellite updated as self-registered Sat is no longer supported.

Note: This is a disconnected Satellite scenario where ISS is not applicable:

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html-single/content_management_guide/#Using_ISS

Customer Setup:

Red Hat CDN
         /\
          |
Satellite 6 Synchronisation Host
          | <= There is no direct link between these 2. 
          |    Contents are copied to a disk and transferred to disconnected   
         \/
Disconnected Satellite (no internet access)-->  Capsule  <--Red Hat Clients
         /\
          |
Red Hat Clients

Comment 2 Andrew Dahms 2018-04-11 05:17:33 UTC
Assigning to rdickens for review.

Comment 27 Rich Jerrido 2018-09-26 12:50:44 UTC
*** Bug 1579849 has been marked as a duplicate of this bug. ***

Comment 34 jalviso 2019-05-29 22:59:47 UTC
@David Voss, do we have any progress we can relay to the customer regarding this documentation request?
The customer is waiting on this docs inclusion.

Regards,

Josephine

Comment 40 Karie 2019-10-24 12:23:59 UTC
Hello Josephine

This documentation is planning to be developed  and delivered in the 6.7 time frame.

Karie Cook


Note You need to log in before you can comment on or make changes to this bug.