Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1564447 - reservesys didn't reserve the machine
Summary: reservesys didn't reserve the machine
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Retired
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 10:20 UTC by Tereza Cerna
Modified: 2020-10-21 14:17 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-21 14:13:21 UTC


Attachments (Terms of Use)

Description Tereza Cerna 2018-04-06 10:20:30 UTC
Task /distribution/reservesys didn't reserve system and immediately returned it to the beaker. It ended with status Pass.

Problem occured in:
https://beaker.engineering.redhat.com/jobs/2409801

From beaker job:

Run ID       Task                     	StartTime[FinishTime][Duration]   Status      Result
--------------------------------------------------------------------------------------------
T:70268309   /distribution/reservesys   2018-04-05 12:05:25 +02:00        Completed   Pass 	 
                                        2018-04-05 12:06:41 +02:00
                                        0:01:16

             RESERVE_SKIP               2018-04-05 12:06:33 +02:00                    Pass

Comment 1 Dan Callaghan 2018-04-08 23:41:38 UTC
You used RESERVE_IF_FAIL=1 with the /distribution/reservesys task, so I guess you are saying: you expected it to reserve because the previous task 
/distribution/errata/tps had failed, but instead it skipped the reservation as if all tasks had passed.

This is likely a dupe of bug 1369431.


Note You need to log in before you can comment on or make changes to this bug.