Bug 156460 - "Invalid compressed format (err=1)" error on boot
"Invalid compressed format (err=1)" error on boot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-04-30 14:03 EDT by Dawid Zamirski
Modified: 2015-01-04 17:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-05 15:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dawid Zamirski 2005-04-30 14:03:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:

Since the update to rawhide20050427 I'm unable to boot the system with any kernel, including the most recent 1276 build, except 2.6.11-1.1240_FC4 which works ok. Higher builds of the kernel throw the "Invalid compressed format" error. I was able to boot 126x kernels before the update. I tried to revert back initscripts an mkinitrd packages to 8.07-1.x86_64 and 4.2.8-1.x86_64 respectively, but this didn't solve the problem. I also disabled SELinux and checked my file system with reiserfsck but this didn't help either. My system specs are below:

CPU: AMD Athlon 64 3500+
Motherboard: MSI K8T Neo2 Platinum
HDD: Seagate ST3200822A and WDC WD1200JB - both connected to the standard IDE controller.
File system: reiserfs on all partitions inluding /boot

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Turn on the computer
2. Select any kernel in GRUB (except 1240)
3. Boot selected kernel

Actual Results:  Error message "System halted" "Invalid Comressed format (err=1)"

Expected Results:  system startup

Additional info:

[root@athlon64 ~]# rpm -q mkinitrd
[root@athlon64 ~]# rpm -q initscripts
[root@athlon64 ~]# rpm -q kernel
[root@athlon64 ~]# rpm -q grub
Comment 1 Dave Jones 2005-05-01 04:03:13 EDT
can you try running memtest for a while ? This smells like bad memory.
Especially as this is the only instance of this we've seen reported, and I've
personally run all recent x86-64 kernels on several different models.
Comment 2 Dawid Zamirski 2005-05-02 09:29:33 EDT
Ok, I'll do the testing when I get back home from work. I doubt that it's a 
memory problem because it happened just right after 04/27 rawhide update and 
the before the update all the kernels booted up correctly. I suspect it's 
caused by reiserfs as /boot fielsystem.. 
Comment 3 Dawid Zamirski 2005-05-02 18:57:22 EDT
Hello again :-)

Memtest passsed sucessfully, so that's not the RAM issue. I played with kernels
installed and discovered that suddenly 1275 boots ok (it was failing when I
checked it after the 04/27 update). Some of my kernels give slightly different
error messges but all of them seem to be realtd to the compressed kernel image.

Builds 1251 and 1268 throw the following error:
Error 13: Invalid or unsupported executable format.

Build 1261:
RAMDISK: ran out of compressed data
Kernel panic - not syncing: VFS: unable to mount fs on unknown-block(22,2)

The rest of my kernels throw just the "Invalid compressed format" message.

I'll perform clean reinstall of my system after FC4T3 comes out because I have
too much mess on my system which, I think, is the cause of the problems. 
Comment 4 Dawid Zamirski 2005-05-12 20:02:57 EDT

I have just made a clean install of FC4T3 and kernel image decompressess
correctly, however right after that it karshes with the following message:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(22,2)

Now, I'm going to make another attempt, but I will change filesystem to ext3 on
Comment 5 Dawid Zamirski 2005-05-12 20:36:38 EDT
Ok, I'm back with good news :-) 

Changing the filesystem to ext3 solved the problem. Another little thing that
has been fixed by the filesystem change was that I was able to see the splash
image in grub - I had a black background before on reiserfs after one of rawhide
updates on FC4T2.
Comment 6 Dan Hollis 2005-05-30 04:52:58 EDT
i can duplicate this also. i opened a more specific bug for this - #159123
Comment 7 Dan Hollis 2005-05-31 00:45:30 EDT
since this is reiserfs specific this should be closed WONTFIX same as 159123.
Comment 8 Peter Jones 2005-06-15 20:02:19 EDT
This sounds like the initrd is corrupt.  Can somebody do this with one that
didn't work:

mkdir tmp
cd tmp
zcat /boot/initrd-VERSION | cpio -dvi

and see if it actually works?
Comment 9 Dan Hollis 2005-06-15 20:29:23 EDT
since this is reiserfs specific this should be closed WONTFIX same as 159123.
Comment 10 Dave Jones 2005-07-05 15:59:34 EDT
reiserfs bugs should be reported in http://bugme.osdl.org

Fedora will inherit any fixes that occur upstream on rebases to newer kernels.
Comment 11 Dan Hollis 2005-07-05 16:50:49 EDT
sadly few kernel developers appear to read bugme.osdl.org

Note You need to log in before you can comment on or make changes to this bug.