Bug 1564661 - Reporting Column Consolidation and Styling Not Compatible
Summary: Reporting Column Consolidation and Styling Not Compatible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.9.0
Hardware: All
OS: All
low
low
Target Milestone: GA
: cfme-future
Assignee: Eric Winchell
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 20:10 UTC by Dustin Scott
Modified: 2019-08-22 00:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 15:26:30 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Dustin Scott 2018-04-06 20:10:43 UTC
Description of problem:

When consolidating columns, styling is unable to be used in order to highlight key values in columns.


Version-Release number of selected component (if applicable):

5.9.0-22


How reproducible:

100%


Steps to Reproduce:

Ensure OCP with Hawkular is setup and collecting metrics.  I'm sure the same behavior will occur with other providers, but this is where we tickled this bug at.

1. Create a new report in the Performance - ContainerNodes Category (Performance Interval)
2. Select the fields 'Asset Name', and 'CPU - %Used'
3. Set 'Asset Name' as the consolidated Column
4. Set 'Average' and 'Maximum' as the calculations on the consolidated column.
5. Set styling as 'Red Background' '>=' '0' . This will ensure that most columns of any up nodes will have data and should theoretically turn red.
6. Save the report
7. Queue the report

Alternatively, do the same as above without any column consolidation, and the report styles the columns as intended.

Actual results:

Consolidated columns are not highlighted based on styling settings.


Expected results:

Consolidated columns are able to be highlighted just as standard reports without consolidation are able to.


Additional info:


Note You need to log in before you can comment on or make changes to this bug.