Bug 1564696 - After DNF system upgrade to F28, some langpack missing which can block Gnome-Shell session to start
Summary: After DNF system upgrade to F28, some langpack missing which can block Gnome-...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: langpacks
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 22:51 UTC by seb
Modified: 2018-04-08 03:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-08 03:03:46 UTC
Type: Bug


Attachments (Terms of Use)

Description seb 2018-04-06 22:51:19 UTC
Description of problem:

After doing a DNF system upgrade from Fedora 27 to 28, some langpack packages was missing.

The concerned packages are:
- glibc-all-langpacks
- glibc-langpack-fr
- langpacks-fr
- langpacks-en

Theses missing result to:
- Local who cannot more set language to fr_CH
- Gnome-shell who cannot any longer let me connect to my user session (always returning to GDM after login)

And after looking in DNF history, it never record any modification of the packages listed above.



Version-Release number of selected component (if applicable):
Name         : glibc-all-langpacks
Version      : 2.27
Release      : 8.fc28

Name         : glibc-langpack-fr
Version      : 2.27
Release      : 8.fc28

Name         : langpacks-en
Version      : 1.0
Release      : 12.fc28

Name         : langpacks-fr
Version      : 1.0
Release      : 12.fc28




How reproducible:
Do a DNF system upgrade from Fedora 27 to 28 with pre-installed packages:
- glibc-all-langpacks
- glibc-langpack-fr
- langpacks-fr
- langpacks-en


Actual results:
- Local who cannot more set language to fr_CH
- Gnome-shell who cannot any longer let me connect to my user session (always returning to GDM after login)


Expected results:
- No problems

Comment 1 Parag Nemade 2018-04-07 13:59:27 UTC
There are few things missing in you bug report so I assumed them as
1) Your f27 system is updated system by installing latest f27-updates
2) you are running French locale and I used fr_FR.UTF-8 as its easy to set it via region panel of gnome control-center.

I now got fresh f27 test system. Installed all those 4 packages and set locale to fr_FR.UTF-8 and ran dnf system upgrade to f28. It downloaded and updated total 1580 packages. Reboot the test system and i can login using gdm to Fedora 28 system. 

I can see all those 4 packages are there on my system updated to their f28 build rpms.

Sorry but I cannot reproduce your problem.

Comment 2 seb 2018-04-07 16:33:19 UTC
I upgraded from a Fedora 27 updated from latest f27-updates and my locale was set to fr_CH.utf8.

After looking in DNF history I see no indications of removing these 4 packages, but they was missing. After installed themes the problem was solved.

Comment 3 Parag Nemade 2018-04-07 16:59:49 UTC
This should be the issue with your upgrade. Either its problem of mirrors from where you got F28 packages or dnf failed somewhere while upgrading to F28. You can further investigate it by opening a bug against dnf and providing that dnf transaction log in bug report.

I will close this as a NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.