Bug 1564791 - [DOCS] Serious problems with CRI-O documentation
Summary: [DOCS] Serious problems with CRI-O documentation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Negus
QA Contact: Xiaowei Li
Vikram Goyal
URL:
Whiteboard:
: 1570142 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-07 22:43 UTC by Scott McCarty
Modified: 2018-06-01 17:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-01 17:00:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Scott McCarty 2018-04-07 22:43:11 UTC
Document URL: 
https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html#ocp-39-technology-preview

Section Number and Name: 
"System Containers for docker, CRI-O"

Describe the issue: 

1. In the table it says that support for docker and CRI-O system containers is deprecated. Then, in the link [1] it shows how to configure docker to run as a system container. 

2. The link [1] has no explanation of how to run CRI-O as a system container.

3. The release notes [2] suggest that the default installation of CRI-O will be as a system container - "This setting pulls the openshift3/cri-o system container image from the Red Hat Registry by default." 

4. I attempted an install of OCP 3.9 with Ansible inventory setting (openshift_use_crio=true) and it fails. I tried both an RPM install and a Container install, neither option will cause CRI-O to be installed.

5. In the release notes [2], it says - "The atomic-openshift-node service must be RPM- or system container-based when using CRI-O" but there are is no description of how to run atomic-openshift-node as a system container anywhere in the release notes, nor under the advanced installation instructions for system containers [4].

6. There is a reference to running "kublet" as a system container in the release notes [2] - "System Container for installer and Kubelet" - but, when you follow that link [3], there is only a description of how to run the installer as a system container.


Suggestions for improvement: 

Sorry for the complex description, but I have installed/uninstalled OCP 3.9 in every possible permutation. There is too much conflicting documentation to determine what the right way is. I have even manually installed the RPMs, then ran the Ansible installer, but that fails as well. 

Additional information: 

[1]: 
https://docs.openshift.com/container-platform/3.9/install_config/install/advanced_install.html#advanced-install-configuring-system-containers

[2]: https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html

[3]: https://docs.openshift.com/container-platform/3.9/install_config/install/advanced_install.html#running-the-advanced-installation-system-container

[4]: https://docs.openshift.com/container-platform/3.9/install_config/install/advanced_install.html#advanced-install-configuring-system-containers

Comment 1 Chris Negus 2018-04-24 15:56:50 UTC
Need to rewrite CRI-O docs, based on the above description. Consider moving CRI-O docs into main docs set once corrected.

Comment 4 Kathryn Alexander 2018-04-26 13:21:17 UTC
*** Bug 1570142 has been marked as a duplicate of this bug. ***

Comment 5 Chris Negus 2018-06-01 17:00:01 UTC
These issues (from above) were corrected in the latest OpenShift 3.9 docs [1]:

1) Description of the CRI-O system container was removed.
2) No need to document how to use CRI-O as a system container.
3) Default CRI-O installation is now noted as being RPM-based.
4) The RPM install is now properly documented.
5) All references to CRI-O as a system container are gone.
6) Reference to kubelet was removed.


[1] https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html#ocp-39-crio


Note You need to log in before you can comment on or make changes to this bug.