Bug 1564805 - [DOCS] Cannot Install CRI-O as part of OCP Quick nor Advanced Install
Summary: [DOCS] Cannot Install CRI-O as part of OCP Quick nor Advanced Install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.9.z
Assignee: Alex Dellapenta
QA Contact: Gan Huang
Vikram Goyal
URL:
Whiteboard:
: 1568585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 00:44 UTC by Scott McCarty
Modified: 2018-05-10 20:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 20:28:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Successful cake-php test screenshot (152.33 KB, image/png)
2018-04-08 02:55 UTC, Scott McCarty
no flags Details

Description Scott McCarty 2018-04-08 00:44:35 UTC
Description of problem:

Version-Release number of the following components:
[root@rhel7 .config]# rpm -q openshift-ansible
openshift-ansible-3.9.14-1.git.3.c62bc34.el7.noarch
[root@rhel7 .config]# rpm -q ansible
ansible-2.4.3.0-1.el7ae.noarch
[root@rhel7 .config]# ansible --version
ansible 2.4.3.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]
How reproducible:

Steps to Reproduce:
1. Follow the CRI-O instructions as provided in the OCP 3.9 Release Notes: https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html#ocp-39-new-features-and-enhancements 
2. Use the following Ansible inventory: https://pastebin.com/0vPuV9hd
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Here's what happens: https://pastebin.com/fticYC5a

Expected results:

I would expect the CRI-O system container to be installed, by default, as described in the release notes.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

https://pastebin.com/rWG5UjfQ

Also, I was able to get the installer to complete by manually installing the cri-o RPM...

Comment 1 Scott McCarty 2018-04-08 02:55:14 UTC
I successfully installed a cluster which uses CRI-O using this Ansible inventory file:

https://pastebin.com/qTm00cZ9

Also, here is the log output of the installer:

https://pastebin.com/QEmd6sE6

Here are the tests I ran:

Test #1: Succeeded
oc new-project validate
oc new-app cakephp-mysql-example
firefox: see screenshot

Test #2: Failed
oc adm diagnostics NetworkCheck

https://pastebin.com/APU92N9r



My guess is this has something todo with the test and how it interacts with CNI. Everything works though, including the routers. Basically, the docs need updated or the installer needs updated - or both. Not sure which is best.

Comment 2 Scott McCarty 2018-04-08 02:55:43 UTC
Created attachment 1418775 [details]
Successful cake-php test screenshot

Comment 3 Johnny Liu 2018-04-09 10:45:48 UTC
QE can not reproduce this bug.

Some question need reporter confirm:
1. Generally you would encounter BZ#1564847, how did you workaround it?
2. Could you attach the whole openshift-ansible installer ouptut?
3. Could you attach atomic-openshift-node service start failure log?

BTW, we never support CRI-O rpm, only CRI-O running in system container, I do not think install CRI-O rpm would help resolve your issue.

Comment 4 Johnny Liu 2018-04-09 11:25:11 UTC
(In reply to Johnny Liu from comment #3)
> QE can not reproduce this bug.
> 
> Some question need reporter confirm:
> 1. Generally you would encounter BZ#1564847, how did you workaround it?
Okay, you did not set openshift_release, so ignore this question.

Comment 5 Johnny Liu 2018-04-10 02:42:15 UTC
Seem like this is similar with https://bugzilla.redhat.com/show_bug.cgi?id=1531271#c3, have you run playbooks/prerequisites.yml prior to playbooks/deploy_cluster.yml ?

Comment 6 Scott McCarty 2018-04-10 17:57:35 UTC
I had run the playbooks/prerequisites.yml first. Maybe you are trying an all in one install, my install was across 7 nodes. Perhaps, that has an effect?

Comment 7 Scott McCarty 2018-04-10 18:00:50 UTC
(In reply to Johnny Liu from comment #3)
> QE can not reproduce this bug.
> 
> Some question need reporter confirm:
> 1. Generally you would encounter BZ#1564847, how did you workaround it?

I didn't see this problem. It's as if the installer didn't try to pull the system container image, nor use it.

> 2. Could you attach the whole openshift-ansible installer ouptut?

Sadly, I didn't save it. I will try to reproduce in a different environment soon, and attach it if I can.

> 3. Could you attach atomic-openshift-node service start failure log?

Same for this one.

> 
> BTW, we never support CRI-O rpm, only CRI-O running in system container, I
> do not think install CRI-O rpm would help resolve your issue.

Interesting, the ONLY way I could get the installer to complete was if I installed the RPM manually, then ran the OCP installer. I tried many, many different combinations and permutations. I wrote this blog entry explaining how I got it to work:

https://medium.com/cri-o/how-to-run-cri-o-1-9-10-with-openshift-container-platform-3-9-and-red-hat-enterprise-linux-7-4-c8ecf47c66b5

Comment 8 Scott Dodson 2018-04-11 14:49:15 UTC
We need to update the documentation make it clear that RPM based installs of crio are the only supported method right now, critical flaws in system container based deployments were found at the last minute.

These two should work for you

openshift_crio_use_rpm=True
openshift_use_crio=True

Comment 9 Scott Dodson 2018-04-18 20:47:20 UTC
*** Bug 1568585 has been marked as a duplicate of this bug. ***

Comment 10 Alex Dellapenta 2018-04-19 18:56:29 UTC
https://github.com/openshift/openshift-docs/pull/8811

Comment 11 Scott McCarty 2018-04-19 19:16:22 UTC
(In reply to Scott Dodson from comment #8)
> We need to update the documentation make it clear that RPM based installs of
> crio are the only supported method right now, critical flaws in system
> container based deployments were found at the last minute.
> 
> These two should work for you
> 
> openshift_crio_use_rpm=True
> openshift_use_crio=True

Well, at least I know I am not crazy :-) I swear I tried, and no system containers got installed. I shall try those options in a test install. Thanks for that information.

Comment 12 Vikas Laad 2018-04-19 19:21:52 UTC
I tried this yesterday

openshift_crio_use_rpm=True

This will install cri-o as rpm not system container and it should work.

Scott, if we are not supporting cri-o system container openshift_crio_use_rpm=True should be true by defaule ?

Comment 13 Gan Huang 2018-04-24 06:58:43 UTC
RPM based cri-o installation is completed successfully in openshift-ansible-3.9.22-1.git.7.92620c6.el7.noarch.rpm. Also the S2I build succeeded.

openshift_crio_docker_gc_node_selector={"role": "node"}
openshift_crio_use_rpm=true


Note You need to log in before you can comment on or make changes to this bug.