Bug 1564937 - improve documentation around new GCP ansible installer variables
Summary: improve documentation around new GCP ansible installer variables
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 00:38 UTC by raffaele spazzoli
Modified: 2019-11-21 12:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 12:49:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description raffaele spazzoli 2018-04-09 00:38:02 UTC
Document URL:
https://docs.openshift.com/container-platform/3.9/install_config/configuring_gce.html#gce-configuring-masters-ansible 

Section Number and Name: 
Configuring OpenShift Container Platform Masters for GCE with Ansible

Describe the issue: 
the new variables:
openshift_gcp_project and openshift_gcp_prefix are mentioned but it is not explained what they are used for.
Particularly the prefix is not self explanatory and should be more thoroughly explained (what is used for, what are the valid formats, what type of uniqueness expectations are there).
The new openshift_gcp_multizone is not mentioned, but should be mentioned and explained. Particularly because the default seems to have changed from multizone to monozone, so previous builds will probably break (mine did)

The ansible task seemed to use other variables. You should decide whether they should be documented.

Comment 1 Stephen Cuppett 2019-11-21 12:49:00 UTC
OCP 3.6-3.10 is no longer on full support [1]. Marking un-triaged bugs CLOSED DEFERRED. If you have a customer case with a support exception or have reproduced on 3.11+, please reopen and include those details. When reopening, please set the Version to the appropriate version where reproduced.

[1]: https://access.redhat.com/support/policy/updates/openshift


Note You need to log in before you can comment on or make changes to this bug.