Bug 1565023 - node role is removed after enabling Azure Cloud Provider
Summary: node role is removed after enabling Azure Cloud Provider
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 07:40 UTC by Takayoshi Tanaka
Modified: 2019-11-21 12:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 12:49:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Takayoshi Tanaka 2018-04-09 07:40:51 UTC
Document URL: 
https://docs.openshift.com/container-platform/3.9/install_config/configuring_azure.html


Section Number and Name: 
Applying Configuration Changes

Describe the issue: 
When enabling Azure Cloud provider by following the document [1], node role is removed. To ensure the proper scheduling, a manual step is required.

Suggestions for improvement: 
Add the following command to the document.

$ oc label node <master_node_name> node-role.kubernetes.io/master=true
$ oc label node <node_name> node-role.kubernetes.io/compute=true


Additional information: 

We can see the node role before enabling Azure Cloud provider.
$ oc describe node <node_name>
Name:               <node_name>
Roles:              master
Labels:             beta.kubernetes.io/arch=amd64
...

After restarting the node service to enable Azure cloud provider [2], Roles is none.

$ oc describe node <node_name>
Name:               <node_name>
Roles:              <none>

Since some buildconfigs or deploymentconfigs depends on this label, we have to recover the label manually.

Comment 1 Stephen Cuppett 2019-11-21 12:49:18 UTC
OCP 3.6-3.10 is no longer on full support [1]. Marking un-triaged bugs CLOSED DEFERRED. If you have a customer case with a support exception or have reproduced on 3.11+, please reopen and include those details. When reopening, please set the Version to the appropriate version where reproduced.

[1]: https://access.redhat.com/support/policy/updates/openshift


Note You need to log in before you can comment on or make changes to this bug.