Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565068 - Clang build just dies on 64 bit systems
Summary: Clang build just dies on 64 bit systems
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 10:07 UTC by Rudolf Kastl
Modified: 2018-05-29 12:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 13:03:54 UTC


Attachments (Terms of Use)

Description Rudolf Kastl 2018-04-09 10:07:58 UTC
Description of problem:
The clang build just dies on 64bit build systems


Actual results:
Build dies on 64bit systems f26 f27 and f28
Local build of clang works. Tried multiple times and 


Expected results:
Build will just work

Additional info:
Here are the logs:

64bit failed build e.g. for f27 x86_64:
https://copr-be.cloud.fedoraproject.org/results/che/llvm/fedora-27-x86_64/00738810-clang/build.log.gz

32bit successful build e.g. for f27 x86:
https://copr-be.cloud.fedoraproject.org/results/che/llvm/fedora-27-i386/00738810-clang/builder-live.log

NOTE: I have cancelled the build after it failed for 64bit again.

Comment 1 clime 2018-04-09 10:52:53 UTC
Well, what about those errors here:

BUILDSTDERR: usr/bin/ld: cannot find /usr/lib64/libatomic.so.1.2.0
BUILDSTDERR: usr/bin/ld: cannot find /usr/lib64/libatomic.so.1.2.0
BUILDSTDERR: collect2: error: ld returned 1 exit status
BUILDSTDERR: collect2: error: ld returned 1 exit status
BUILDSTDERR: make[2]: *** [tools/extra/clangd/CMakeFiles/clangDaemon.dir/build.make:565: lib64/libclangDaemon.so.7] Error 1
BUILDSTDERR: make[2]: *** [tools/extra/clangd/CMakeFiles/clangDaemon.dir/build.make:565: lib64/libclangDaemon.so.7] Error 1
BUILDSTDERR: make[1]: *** [CMakeFiles/Makefile2:7852: tools/extra/clangd/CMakeFiles/clangDaemon.dir/all] Error 2
BUILDSTDERR: make[1]: *** [CMakeFiles/Makefile2:7852: tools/extra/clangd/CMakeFiles/clangDaemon.dir/all] Error 2

It seems they are related.

Comment 2 Miroslav Suchý 2018-04-09 13:03:54 UTC
Yes. This is definitely a packaging issue.

Comment 3 Markus S. 2018-05-29 11:16:00 UTC
(In reply to Miroslav Suchý from comment #2)
> Yes. This is definitely a packaging issue.

How are Fedora packaging issues not bugs?

Comment 4 Pavel Raiskup 2018-05-29 11:35:59 UTC
Markus that seems to be a bug in the package that was submitted for build
in copr service;  so the fix needs to be done by the build submitter.

Did you want to submit build against product=Fedora, component=clang?
Because this is not a bug in Copr product (the build system service).

Comment 5 Pavel Raiskup 2018-05-29 11:39:49 UTC
Drat, rewriting this... totally messed... comment :-):
(In reply to Pavel Raiskup from comment #4)
> Did you want to submit build against product=Fedora, component=clang?
> Because this is not a bug in Copr product (the build system service).

Didn't you want to fill a bug against product=Fedora, component=clang?


Note You need to log in before you can comment on or make changes to this bug.