Bug 1565177 - update from 6.2 -> 6.3 results in no content views shown from webui
Summary: update from 6.2 -> 6.3 results in no content views shown from webui
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Upgrades
Version: 6.3.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 14:34 UTC by Reartes Guillermo
Modified: 2018-04-20 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 15:54:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
sat 6.3.0 upgraded from 6.2.14 with empty content views from web ui (33.88 KB, image/png)
2018-04-09 14:36 UTC, Reartes Guillermo
no flags Details
hammer output, content views are shown (but it did not perform any operation yet) (1.87 KB, text/plain)
2018-04-09 14:37 UTC, Reartes Guillermo
no flags Details
sosreport empty cviews from webui but not from hammer (19.38 MB, application/x-xz)
2018-04-09 14:41 UTC, Reartes Guillermo
no flags Details
foreman-debug missing cviews from webui but not from hammer (9.80 MB, application/x-xz)
2018-04-09 14:44 UTC, Reartes Guillermo
no flags Details
working content views (Chromium 59.0) (337.69 KB, image/png)
2018-04-10 22:35 UTC, Reartes Guillermo
no flags Details
empty content views with firefox 54.0 (185.29 KB, image/png)
2018-04-10 22:36 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2018-04-09 14:34:21 UTC
Description of problem:

After upgrading from 6.2.14 (fully updated prior to upgrade to 6.3) to 6.3.0.

Version-Release number of selected component (if applicable):
6.3.0

How reproducible:
always

Steps to Reproduce:
1. update 6.2 to latest version
2. Upgrade 6.2.x to 6.3.x 
3. All is ok, but no content views are show from webui, in hammer they are shown

Actual results:
no content view management possible from webui

Expected results:
being able to manage content views

Additional info:
i did not test yet if hammer can operate content views, only that they are shown.

Comment 1 Reartes Guillermo 2018-04-09 14:36:17 UTC
Created attachment 1419345 [details]
sat 6.3.0 upgraded from 6.2.14 with empty content views from web ui

Comment 2 Reartes Guillermo 2018-04-09 14:37:20 UTC
Created attachment 1419346 [details]
hammer output, content views are shown (but it did not perform any operation yet)

hammer> content-view list --organization-id 3
----------------|---------------------------|--------------------------------------|-----------|---------------------|-----------------------------------------------
CONTENT VIEW ID | NOMBRE                    | LABEL                                | COMPOSITE | LAST PUBLISHED      | REPOSITORY IDS                                
----------------|---------------------------|--------------------------------------|-----------|---------------------|-----------------------------------------------
14              | C_RHEL7                   | C_RHEL7                              | true      | 2018/01/18 12:59:22 | 1082, 1083, 1084, 1085, 1086, 1087, 1088, 1089
2               | Default Organization View | 28d36378-fa4b-4294-81f6-c2bce5688736 |           | 2016/09/10 01:12:44 |                                               
9               | PLUS RHEL7                | PLUS_RHEL7                           |           | 2018/04/07 12:24:31 | 1, 3, 6, 5, 4, 1155, 1156, 96, 411            
6               | RH-VIRT4-RHEL7            | RH-VIRT4-RHEL7                       |           | 2018/04/07 12:44:15 | 1, 6, 5, 552, 551, 1155, 68, 67, 1156         
13              | S_3PARTY7                 | S_3PARTY7                            |           | 2018/01/18 11:05:00 | 411                                           
11              | S_PUPPET                  | S_PUPPET                             |           | 2017/08/18 20:38:43 |                                               
12              | S_RHEL7                   | S_RHEL7                              |           | 2018/01/18 11:14:51 | 1, 3, 6, 5, 4, 46, 96                         
----------------|---------------------------|--------------------------------------|-----------|---------------------|-----------------------------------------------

From Web-UI: No content views.

Comment 3 Reartes Guillermo 2018-04-09 14:41:36 UTC
Created attachment 1419347 [details]
sosreport empty cviews from webui but not from hammer

Comment 4 Reartes Guillermo 2018-04-09 14:44:14 UTC
Created attachment 1419348 [details]
foreman-debug missing cviews from webui but not from hammer

Comment 5 Brad Buckingham 2018-04-10 17:17:47 UTC
Hi Reartes,

Do you have an internal reproducer?

Do you see any errors in the browser console?

Comment 6 Reartes Guillermo 2018-04-10 22:35:07 UTC
> Do you have an internal reproducer?
I did perform the upgrade only once. 

> Do you see any errors in the browser console?
Interesting question, i did test also with chrome and it works.
It seems specific to Firefox.

I will upload both images.

Comment 7 Reartes Guillermo 2018-04-10 22:35:50 UTC
Created attachment 1420112 [details]
working content views (Chromium 59.0)

Comment 8 Reartes Guillermo 2018-04-10 22:36:24 UTC
Created attachment 1420113 [details]
empty content views with firefox 54.0

Comment 9 Reartes Guillermo 2018-04-13 18:07:49 UTC
Hi, 

After updating to 6.3.1 it is working correclty.

Thanks.

Comment 10 Brad Buckingham 2018-04-18 17:35:44 UTC
Reartes,

Thanks for the update.

Unfortunately, I have not been able to reproduce this issue.  I do not see anything in the logs that indicate why it may have occurred.  I am also not seeing anything in 6.3.1 that should have specifically resolved it.

In the screenshot in comment 8 for firefox, the 404 that is shown for nutupane.html is suspicious.  The reason being nutupane is no longer used in 6.3; therefore, I am wondering if perhaps there was a browser caching issue.

I lean towards closing this for now and re-opening if we additional reports.  

Thoughts?

Comment 11 Reartes Guillermo 2018-04-18 23:42:10 UTC
Hi,

Since this Sat6 is la lab environment, it is not on 7x24 and the desktop from i access it was also powered off some time in between i really doubt that it was a caching issue (or an improper excessive caching/bug in Firefox). I also remember to ran the installer and the issue remained. Only after errata 6.3.1 did it went away.

Closing is the right thing to do, of course.

Cheers.

Comment 12 Brad Buckingham 2018-04-20 15:54:10 UTC
Closing for now.  If someone re-encounters this issue, feel free to re-open with additional details.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.