Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565290 - [abrt] relval: get_response(): report_results.py:81:get_response:EOFError: EOF when reading a line
Summary: [abrt] relval: get_response(): report_results.py:81:get_response:EOFError: EO...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: relval
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Williamson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2d2c31cfbe66aecfa3063db1813...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 19:26 UTC by pmkellly
Modified: 2018-11-12 13:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-12 13:03:10 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: cgroup (399 bytes, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: cpuinfo (1007 bytes, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: environ (5.35 KB, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: mountinfo (3.71 KB, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details
File: open_fds (295 bytes, text/plain)
2018-04-09 19:26 UTC, pmkellly
no flags Details

Description pmkellly 2018-04-09 19:26:17 UTC
Description of problem:
Relval quit while I was doing the login at the web page.

Version-Release number of selected component:
relval-2.2.1-2.fc28

Additional info:
reporter:       libreport-2.9.4
cmdline:        /usr/bin/python3 /usr/bin/relval report-results
crash_function: get_response
exception_type: EOFError
executable:     /usr/bin/relval
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.0-300.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
report_results.py:81:get_response:EOFError: EOF when reading a line

Traceback (most recent call last):
  File "/usr/bin/relval", line 11, in <module>
    load_entry_point('relval==2.2.1', 'console_scripts', 'relval')()
  File "/usr/lib/python3.6/site-packages/relval/cli.py", line 540, in main
    args.func(args, site)
  File "/usr/lib/python3.6/site-packages/relval/cli.py", line 483, in report_results
    args.compose, args.testtype, modular=args.modular)
  File "/usr/lib/python3.6/site-packages/relval/report_results.py", line 233, in report_results
    confirm = get_confirm()
  File "/usr/lib/python3.6/site-packages/relval/report_results.py", line 90, in get_confirm
    accepted=('y', 'n'))
  File "/usr/lib/python3.6/site-packages/relval/report_results.py", line 81, in get_response
    resp = input(prompt)
EOFError: EOF when reading a line

Local variables in innermost frame:
check: <function get_response.<locals>.check at 0x7f63cbd53510>
accfunc: None
accepted: ('y', 'n')
helptext: 'Answer y or n'
prompt: 'Confirm y/n? '

Comment 1 pmkellly 2018-04-09 19:26:20 UTC
Created attachment 1419547 [details]
File: backtrace

Comment 2 pmkellly 2018-04-09 19:26:21 UTC
Created attachment 1419548 [details]
File: cgroup

Comment 3 pmkellly 2018-04-09 19:26:22 UTC
Created attachment 1419549 [details]
File: cpuinfo

Comment 4 pmkellly 2018-04-09 19:26:24 UTC
Created attachment 1419550 [details]
File: environ

Comment 5 pmkellly 2018-04-09 19:26:25 UTC
Created attachment 1419551 [details]
File: mountinfo

Comment 6 pmkellly 2018-04-09 19:26:26 UTC
Created attachment 1419552 [details]
File: namespaces

Comment 7 pmkellly 2018-04-09 19:26:27 UTC
Created attachment 1419553 [details]
File: open_fds

Comment 8 Adam Williamson 2018-04-09 20:06:18 UTC
Is this reproducible? Looks like some kind of race between the auth and the CLI bits, but it'd help to be able to reproduce it.

Comment 9 pmkellly 2018-04-10 17:08:59 UTC
When I started relval to enter the rest of my day's test results it crashed again. I had just entered my FAS password. When I opened the link at the bottom of the terminal, the web login came up and said I was unauthorized, but there was a link on the web page to try logging in again. I did that and it seemed to work. Then I started relval again and it worked okay. I filed the report which is pending on Problem Reporting.

Comment 10 pmkellly 2018-11-12 13:03:10 UTC
I am closing this as part of cleaning up old bugs. I haven't had this problem in a while now. If it recurs I will file a new bug.


Note You need to log in before you can comment on or make changes to this bug.