Bug 1565446 - Lack of builder resources on amd64 and i386
Summary: Lack of builder resources on amd64 and i386
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: x86_64
OS: All
unspecified
medium
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 03:25 UTC by Marc Dequènes (Duck)
Modified: 2018-04-16 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-14 08:40:26 UTC


Attachments (Terms of Use)

Description Marc Dequènes (Duck) 2018-04-10 03:25:49 UTC
Description of problem:
Building `needrestart` usually took 2-8 minutes overall on various distro/arch combination. Yesterday build #739049 took one hour, and today build #739155 after three hours is still blocked waiting for builder's availability.

Maybe it's a special time/event and this is going to be transient. I see long running builds in the status page so that could explain. Nevertheless it seems the number of builders for these very popular architectures is scarce.

Please note I'm not requesting special treatment. If this is going to be very temporary, then feel free to close this BR. If there's a real problem and more resources are needed, then we (OSAS) could vouch for this service's usefulness. I wonder if we might also be able to help more directly.

Comment 1 clime 2018-04-10 07:47:42 UTC
Thank you. The problem is that COPR currently operates on an old OpenStack cloud infrastructure where the Cloud controller repeteadly suffers from memory leaks, which causes lack of available builders. The plan is to move it to a new platform in the upcoming weeks. I hope we can do it fast. Meanwhile, we somehow need to maintain and live with the current platform.

Comment 2 Marc Dequènes (Duck) 2018-04-10 08:53:00 UTC
Thanks a lot for letting me know. It's great there is a plan for improvement.
As we say in here: ganbarimashō!

Comment 3 clime 2018-04-14 08:40:26 UTC
Hello, actually there was a concrete bug in the current OpenStack setup:

https://pagure.io/fedora-infrastructure/issue/6854

which is now fixed. Situation should be much improved now.

Comment 4 Marc Dequènes (Duck) 2018-04-16 02:20:06 UTC
Thanks a lot :-)


Note You need to log in before you can comment on or make changes to this bug.