Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565840 - upgrade of PYPY fails
Summary: upgrade of PYPY fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pypy
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Cyprian
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 22:00 UTC by George R. Goffe
Modified: 2018-04-17 03:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 03:10:56 UTC
Type: Bug


Attachments (Terms of Use)
flat log file of attempted upgrade of PYPY (12.28 KB, text/plain)
2018-04-10 22:00 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2018-04-10 22:00:16 UTC
Created attachment 1420099 [details]
flat log file of attempted upgrade of PYPY

Description of problem:
Attepmting to upgrade this system produces several error messages (see enclosed log)

Version-Release number of selected component (if applicable):
~# rpm -q pypy
pypy-5.10.0-1.fc29.x86_64
~# rpm -q pypy3
pypy3-5.10.1-4.fc29.x86_64


How reproducible:
always

Steps to Reproduce:
1.dnf -y --best upgrade pypy-devel.x86_64 pypy-libs.x86_64 pypy.x86_64
2.
3.

Actual results:
see additional info below and included log

Expected results:
clean and upgraded system

Additional info:


# is this dependency coded correctly considering that pypy-5.10 is the current level?


Running transaction check
Error: transaction check vs depsolve:
pypy = 5.9.0 is needed by (installed) sfact-.0-19.20130128gitbc56c68.fc28.x86_64
pypy = 5.9.0 is needed by (installed) skeinforge-12.03.14-29.fc28.x86_64

To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.

Unsatisfied dependencies for skeinforge-12.03.14-29.fc28.x86_64:
        pypy = 5.9.0 is needed by (installed) skeinforge-12.03.14-29.fc28.x86_64


You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.

# wrong!

The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

Comment 1 Miro Hrončok 2018-04-10 22:24:21 UTC
After all pypy upgrades, both skeinforge and sfact need to be rebuilt. This haven't been coordinated this time. I'm on it.

Comment 2 Miro Hrončok 2018-04-10 22:35:40 UTC
Note: Since the recent change, this will only be needed during mayor and minor upgrades and not during patch upgrades.

E.g.

5.10.5 to 5.10.6 will not need skeinforge and sfact rebuild.
5.10.6 to 5.11.0 will still need it.

Comment 3 Fedora Update System 2018-04-10 22:52:10 UTC
sfact-0.0-20.20130128gitbc56c68.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c68f8c35ea

Comment 4 Fedora Update System 2018-04-10 22:52:20 UTC
skeinforge-12.03.14-30.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-bb9a677843

Comment 5 Fedora Update System 2018-04-11 22:34:24 UTC
skeinforge-12.03.14-31.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b010f42633

Comment 6 Fedora Update System 2018-04-11 22:34:44 UTC
sfact-0.0-21.20130128gitbc56c68.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fad19e0df2

Comment 7 Fedora Update System 2018-04-11 22:57:53 UTC
sfact-0.0-20.20130128gitbc56c68.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c68f8c35ea

Comment 8 Fedora Update System 2018-04-11 22:57:57 UTC
skeinforge-12.03.14-30.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-bb9a677843

Comment 9 Fedora Update System 2018-04-13 16:30:25 UTC
skeinforge-12.03.14-31.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b010f42633

Comment 10 Fedora Update System 2018-04-13 16:30:29 UTC
sfact-0.0-21.20130128gitbc56c68.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-fad19e0df2

Comment 11 Fedora Update System 2018-04-17 03:10:56 UTC
skeinforge-12.03.14-31.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-04-17 03:11:00 UTC
sfact-0.0-21.20130128gitbc56c68.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.