Bug 1566009 - qt5-qtbase breaks qt5-qtwebkit, qt5-qtdeclarative etc. and thus breaks the update.
Summary: qt5-qtbase breaks qt5-qtwebkit, qt5-qtdeclarative etc. and thus breaks the up...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qt5-qtbase
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 10:29 UTC by yashtr
Modified: 2018-04-11 11:17 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 11:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
This is the result i get while upgrading (129.39 KB, image/png)
2018-04-11 10:29 UTC, yashtr
no flags Details

Description yashtr 2018-04-11 10:29:17 UTC
Created attachment 1420259 [details]
This is the result i get while upgrading

Description of problem: In the recent redhat 7.5 release qt5 gets updated to 5.9.2 while other packages in the epel such as qt5-qtwebkit and qt5-qtdeclarative are at the version 5.6.2. Doing a "sudo yum update" breaks existing applications depending on qt5-qtwebkit and thus breaking the update.


Version-Release number of selected component (if applicable):
the current version (in 7.5 release) of qt5-qtbase package is 5.9.2, while the epel still holds the above-mentioned packages at version 5.6.2.


Steps to Reproduce:
1. Install qt5-qtwebkit before update.
2. sudo yum update
3. qt5-qtwebkit is broken as qt5-qtbase gets updated to higher version.

Actual results:
The system can not upgrade not without compromising the application dependent 
qt5-qtwebkit.

Expected results:
qt5-qtwebkit should have been included with redhat repos and shoud have been in sync with qt5-qtbase.

Comment 2 Jan Grulich 2018-04-11 11:17:19 UTC
We cannot include qtwebkit mainly because of security reasons. Another solution to this would be to update qt5-qtwebkit in epel.


Note You need to log in before you can comment on or make changes to this bug.