Bug 1566127 - Support behavioural changes of include_tasks with tags for ansible 2.5
Summary: Support behavioural changes of include_tasks with tags for ansible 2.5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-ansible-collection
Classification: oVirt
Component: disaster-recovery
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Maor
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 15:08 UTC by Maor
Modified: 2018-05-10 06:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:33:02 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ovirt-ansible-disaster-recovery/pull/42 0 None None None 2018-04-12 11:58:10 UTC

Description Maor 2018-04-11 15:08:05 UTC
Description of problem:
We should support the recent change of https://github.com/GovTechSG/kms-aes/issues/4 which related to issue - https://github.com/ansible/ansible/issues/35459 - [2.5] tagged include_tasks with --tags not executed

In ansible 2.5 the disaster recovery will not get executed since it is working with include_tasks.
Based on https://github.com/oVirt/ovirt-ansible-disaster-recovery/issues/13

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run failover/failback/generate_map
2.
3.

Actual results:
Nothing get execute

Expected results:
It should get execute

Additional info:

Comment 1 Maor 2018-04-11 15:11:35 UTC
Can we add a blocker flag on this one?

Comment 2 Elad 2018-04-26 12:10:14 UTC
The fixing patch is not part of 4.2.3-2 build. Moving back to ASSIGNED

Comment 3 Maor 2018-04-26 13:36:33 UTC
Move to Modify, the fix is good it is only not part of the build

Comment 4 Sandro Bonazzola 2018-05-04 11:12:48 UTC
(In reply to Maor from comment #3)
> Move to Modify, the fix is good it is only not part of the build

Is this in 4.2.3 RC4? 
# ovirt-ansible-disaster-recovery-0.4
https://github.com/oVirt/ovirt-ansible-disaster-recovery/releases/tag/0.4

If so, please move to QE

Comment 5 Elad 2018-05-08 09:19:52 UTC
ovirt-ansible disaster recovery works properly with ansible 2.5


Used:
ovirt-ansible-disaster-recovery-0.4-1.el7ev.noarch
ansible-2.5.2-1.el7ae.noarch

Comment 6 Sandro Bonazzola 2018-05-10 06:33:02 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.