Bug 156624 - there should be correlation between nodes in the config and nodes in mgmt tab
there should be correlation between nodes in the config and nodes in mgmt tab
Status: CLOSED DEFERRED
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-02 13:05 EDT by Corey Marthaler
Modified: 2009-04-16 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 12:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-05-02 13:05:25 EDT
Description of problem:
The MGMT stuff should directly tie into the config information. The nodes which
you define (which I still argue should have icons) should be the nodes which
have the status and modes. Currently, the MGMT tab of the GUI doesn't care what
nodes you have defined, because it only asks gulm and cman for status info
anyways, which can result in a mgmt info being completely different from your
config information. If all of this was tied together, there would be no need for
tabs, you could just define a node and then the MGMT stuff decides wheither or
not that node has status or modes.
Comment 1 Corey Marthaler 2005-05-04 11:12:35 EDT
Another observation relating to this issue, when I have an up and runing three
node cluster, and I add a couple new nodes (one a legit node and one a bogus
node), and then propogate to "cluster", only the original three nodes get sent
the additions. The newly added legit node never receives the new config, and
there is never an error that the bogus node never got it. There really is no
correlation between the two tabs and this will probably confuse users.
Comment 2 Paul Kennedy 2005-05-06 09:57:19 EDT
Along the same lines, when I add a service, save /etc/cluster/cluster.conf, and
click "Send to Cluster", the added service does not appear in the Cluster
Management tab. (It does not show up in the clustat display, either.)
Intuitively, I expect that when I update and propagate the configuration file, 
corresponding changes would appear in the Cluster Management tab. If that is not
the intended design, then the documentation needs to reflect that.
Comment 3 Paul Kennedy 2005-05-06 11:32:58 EDT
Comment #2 is invalid for this bug. The reason the configuration was not being
propagated is because the cluster name had been changed also. You cannot change
the cluster name and propagate the cluster name change to the other nodes.
Comment 4 Jim Parsons 2005-05-09 12:22:00 EDT
The original requirement for this version of the UI was to extend the RHEL3 UI
to support the new locking types, new fence devices, and reworked services
section. The original RHEL3 UI had two separate applications: One for
configuration and one for reporting/management. This UI merged them into one app
by making two separate tabs; one for management, and one for configuration.

The issues in this ticket are important and valuable as we progress to the next
generation UI...but they are not bugs but feature requests, and are deferred -
as nothing here will make it into the current release

Note You need to log in before you can comment on or make changes to this bug.