Bug 1566403 - Colonizer throws traceback messages and exits when user enters invalid gateway
Summary: Colonizer throws traceback messages and exits when user enters invalid gateway
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-colonizer
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Ramakrishna Reddy Yekulla
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 09:08 UTC by Nag Pavan Chilakam
Modified: 2019-04-26 09:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-26 09:54:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
traceback error (250.07 KB, image/png)
2018-04-12 09:09 UTC, Nag Pavan Chilakam
no flags Details

Description Nag Pavan Chilakam 2018-04-12 09:08:07 UTC
Description of problem:
---------------------
see screenshot for the error
While setting up any flavor over any protocol(take nfs in this example), if the user accidentally enters an invalid gateway, colonizer throws traceback messages and exits, instead of throwing a cleaner error and asking user to re-enter the values.


Version-Release number of selected component (if applicable):
--------------
colonizer-1.1.2

How reproducible:
---------------
always

Steps to Reproduce:x
1.run a deployment flavor say gp+nas
2.choose nfs protocol
3.when prompted for gateway enter 192.168.1.1/24 (instead of 192.168.1.1)

Actual results:
----------------
see attached screenshot

Expected results:
-----------------
must throw meaningful error and re-prompt user instead of exiting

Comment 2 Nag Pavan Chilakam 2018-04-12 09:09:21 UTC
Created attachment 1420760 [details]
traceback error

Comment 3 Dustin Black 2018-04-12 19:02:52 UTC
This seems to be explicitly due to putting a '/' in the response. The netaddr module is interpreting the '/' as an attempt to enter a subnet mask into a field where just an IP address is expected.

Comment 4 Dustin Black 2018-04-12 19:25:26 UTC
Upstream commit d2f4934b934bba5cc2bed691df64137f9fe54f15 address this problem.

Comment 8 Ramakrishna Reddy Yekulla 2019-04-26 09:54:05 UTC
Closing the colonizer related bugs as its been put on hold for the time being.


Note You need to log in before you can comment on or make changes to this bug.