Bug 1567192 - Multisite data sync inconsistent when PUTs race with DELETEs
Summary: Multisite data sync inconsistent when PUTs race with DELETEs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW-Multisite
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 3.*
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
URL:
Whiteboard:
: 1567938 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 14:20 UTC by Casey Bodley
Modified: 2019-08-14 14:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-14 14:58:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 22804 None None None 2018-04-13 14:20:46 UTC

Description Casey Bodley 2018-04-13 14:20:46 UTC
Description of problem:

In a multisite configuration where PUTs and DELETEs on the same object race to complete on one zone, other zones are unable to resolve that race during data sync.

This happens when DELETE loses this race (getting an ECANCELED error from the osd), because it writes a successful completion entry to the bucket index log instead of a canceled entry.

How reproducible:

Fairly reproducible in workloads that PUT and DELETE to the same object. The upstream tracker issue http://tracker.ceph.com/issues/22804 includes a cosbench workload that reproduces

Actual results:

Source and destination zones contain a different set of objects after data sync completes.

Expected results:

Source and destination zones contain the same set of objects after data sync.

Comment 3 Matt Benjamin (redhat) 2019-08-14 14:59:16 UTC
*** Bug 1567938 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.